UNIGRAPHICS-NX3
FOR
ENGINEERING DESIGN

By
Parthiban Delli
Ming Leu

UMR
Department of Mechanical and Aerospace Engineering
University of Missouri – Rolla
Rolla, Missouri 65401

This project is funded by the National Science Foundation
Advanced Technological Education Program and
Partners of the Advancement of Collaborative Engineering Education
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.3.2 Model a Shaft</td>
<td>45</td>
</tr>
<tr>
<td>3.4 REFERENCE FEATURES</td>
<td>48</td>
</tr>
<tr>
<td>3.4.1 Datum Plane</td>
<td>48</td>
</tr>
<tr>
<td>3.4.2 Datum Axis</td>
<td>50</td>
</tr>
<tr>
<td>3.5 SWEPT FEATURES</td>
<td>51</td>
</tr>
<tr>
<td>3.5.1 Extruded Body</td>
<td>51</td>
</tr>
<tr>
<td>3.6 REMOVE FEATURES</td>
<td>54</td>
</tr>
<tr>
<td>3.7 EXERCISE - MODEL A WASHER</td>
<td>57</td>
</tr>
<tr>
<td>CHAPTER 4 – FEATURE OPERATIONS</td>
<td>58</td>
</tr>
<tr>
<td>4.1 OVERVIEW</td>
<td>58</td>
</tr>
<tr>
<td>4.2 TYPES OF FEATURE OPERATIONS</td>
<td>58</td>
</tr>
<tr>
<td>4.3 FEATURE OPERATIONS ON MODELS</td>
<td>63</td>
</tr>
<tr>
<td>4.3.1 Model a Hexagonal Screw</td>
<td>63</td>
</tr>
<tr>
<td>4.3.2 Model an L-Bar</td>
<td>68</td>
</tr>
<tr>
<td>4.3.3 Model a Hexagonal Nut</td>
<td>75</td>
</tr>
<tr>
<td>4.3.4 Model a Rack with Instances</td>
<td>78</td>
</tr>
<tr>
<td>4.4 EXERCISE - MODEL A CIRCULAR BASE</td>
<td>83</td>
</tr>
<tr>
<td>CHAPTER 5 – DRAFTING</td>
<td>84</td>
</tr>
<tr>
<td>5.1 OVERVIEW</td>
<td>84</td>
</tr>
<tr>
<td>5.2 DRAFTING OF MODELS</td>
<td>85</td>
</tr>
<tr>
<td>5.2.1 Drafting</td>
<td>85</td>
</tr>
<tr>
<td>5.2.2 Dimensioning</td>
<td>90</td>
</tr>
<tr>
<td>5.2.3 Sectional View</td>
<td>95</td>
</tr>
<tr>
<td>5.2.4 Drafting and Dimensioning of an Impeller hexagonal bolt</td>
<td>96</td>
</tr>
<tr>
<td>5.3 EXERCISE - DRAFTING AND DIMENSIONING OF A CIRCULAR BASE</td>
<td>100</td>
</tr>
<tr>
<td>CHAPTER 6 – SKETCHING</td>
<td>101</td>
</tr>
<tr>
<td>6.1 OVERVIEW</td>
<td>101</td>
</tr>
<tr>
<td>6.2 SKETCHING FOR CREATING MODELS</td>
<td>102</td>
</tr>
<tr>
<td>6.2.1 Model an Arbor press Base</td>
<td>103</td>
</tr>
<tr>
<td>6.2.2 Model an Impeller Lower Casing</td>
<td>115</td>
</tr>
<tr>
<td>6.2.3 Model an Impeller</td>
<td>123</td>
</tr>
<tr>
<td>6.3 EXERCISES</td>
<td>127</td>
</tr>
<tr>
<td>CHAPTER 7 – FREEFORM FEATURE</td>
<td>130</td>
</tr>
<tr>
<td>7.1 OVERVIEW</td>
<td>130</td>
</tr>
<tr>
<td>7.1.1 Creating Freeform Features from Points</td>
<td>130</td>
</tr>
<tr>
<td>7.1.2 Creating Freeform Features from Section Strings</td>
<td>131</td>
</tr>
<tr>
<td>7.1.3 Creating Freeform Features from Faces</td>
<td>133</td>
</tr>
<tr>
<td>7.2 FREEFORM FEATURE MODELING</td>
<td>133</td>
</tr>
<tr>
<td>7.2.1 Modeling with points</td>
<td>133</td>
</tr>
<tr>
<td>7.2.2 Modeling with a point cloud</td>
<td>137</td>
</tr>
<tr>
<td>7.2.3 Modeling with curves</td>
<td>139</td>
</tr>
<tr>
<td>7.2.4 Modeling with curves and faces</td>
<td>142</td>
</tr>
<tr>
<td>7.3 EXERCISE - MODEL A MOUSE</td>
<td>145</td>
</tr>
</tbody>
</table>
CHAPTER 8 – ASSEMBLY MODELING ................................................................. 146
8.1 OVERVIEW ......................................................................................... 146
8.2 TERMINOLOGIES ............................................................................. 146
8.3 ASSEMBLY MODELS ....................................................................... 147
  8.3.1 Top-Down Modeling ................................................................ 147
  8.3.2 Bottom-Up Modeling ................................................................. 148
  8.3.3 Mixing and Matching ................................................................. 148
8.4 MATING CONDITIONS ..................................................................... 148
8.5 IMPELLER ASSEMBLY ..................................................................... 150
8.6 EXPLODED VIEW OF IMPELLER ASSEMBLY ................................ 164
8.7 EXERCISE - ARBOR PRESS ASSEMBLY ....................................... 169

CHAPTER 9- MANUFACTURING ..................................................................... 170
9.1 GETTING STARTED WITH MANUFACTURING MODULE .............. 170
  9.1.1 Creation of Blank .................................................................... 170
  9.1.2 Setting Machining Environment ............................................. 172
  9.1.3 Operation Navigator ................................................................. 173
  9.1.4 Machine Coordinate System (MCS) ......................................... 174
  9.1.5 Geometry Definition ............................................................... 174
9.2 CREATING OPERATION AND PARAMETER SETTING ............... 176
  9.2.1 Creating a new Operation ......................................................... 176
  9.2.2 Tool Creation and Selection ..................................................... 177
  9.2.3 Cut Method ............................................................................ 180
  9.2.4 Step Over and Scallop Height ................................................ 181
  9.2.5 Depth per cut ......................................................................... 182
  9.2.6 Cutting Parameters ................................................................. 183
  9.2.7 Avoidance ............................................................................. 185
  9.2.8 Feedrates .............................................................................. 186
9.3 PROGRAM GENERATION AND VERIFICATION ...................... 188
  9.3.1 Generating Program ................................................................. 188
  9.3.2 Tool Path Display .................................................................. 189
  9.3.3 Tool Path Simulation ............................................................... 189
  9.3.4 Gouge Check ......................................................................... 193
9.4 OPERATION METHODS ..................................................................... 193
  9.4.1 Roughing .............................................................................. 193
  9.4.2 Semi-Finishing ...................................................................... 194
  9.4.3 Finishing Profile .................................................................... 197
  9.4.4 Finishing Contour Surface ..................................................... 205
  9.4.5 Flooring ................................................................................ 210
9.5 POST PROCESSING ......................................................................... 213
  9.5.1 Creating CLSF ....................................................................... 214
  9.5.2 Postprocessing ..................................................................... 216

CHAPTER 10- FINE ELEMENT ANALYSIS .................................................... 218
10.1 INTRODUCTION TO FEA ............................................................... 218
  10.1.1 Element shapes and nodes ................................................... 218
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.1.2 Structure Module</td>
<td>220</td>
</tr>
<tr>
<td>10.1.3 Scenario Navigator</td>
<td>222</td>
</tr>
<tr>
<td>10.1 SCENARIO CREATION</td>
<td>222</td>
</tr>
<tr>
<td>10.2.1 Material Properties</td>
<td>224</td>
</tr>
<tr>
<td>10.2.2 Loads</td>
<td>224</td>
</tr>
<tr>
<td>10.2.3 Boundary Conditions</td>
<td>225</td>
</tr>
<tr>
<td>10.2.4 Meshing</td>
<td>226</td>
</tr>
<tr>
<td>10.3 SOLVING AND RESULT SIMULATION</td>
<td>228</td>
</tr>
<tr>
<td>10.3.1 Solving the Scenario</td>
<td>228</td>
</tr>
<tr>
<td>10.3.2 FEA Result</td>
<td>229</td>
</tr>
<tr>
<td>10.3.2 Simulation</td>
<td>231</td>
</tr>
<tr>
<td>10.4 EXERCISE-ARBORPRESS L-BAR</td>
<td>234</td>
</tr>
</tbody>
</table>
FOREWORD

Unigraphics is one of the world’s most advanced and tightly integrated CAD/CAM/CAE product development solutions. Spanning the entire range of product development, Unigraphics delivers immense value to enterprises of all sizes. It simplifies complex product designs, thus speeding up the process of introducing products to the market.

The Unigraphics software integrates knowledge-based principles, industrial design, geometric modeling, advanced analysis, graphic simulation, and concurrent engineering. The software has powerful hybrid modeling capabilities by integrating constraint-based feature modeling and explicit geometric modeling. In addition to modeling standard geometry parts, it allows the user to design complex free-form shapes such as airfoils and manifolds. It also merges solid and surface modeling techniques into one powerful tool set.

This self-guiding tutorial provides a step-by-step approach for users to learn Unigraphics. It is intended for those with no previous experience with Unigraphics. However, users of previous versions of Unigraphics may also find this tutorial useful for them to learn the new user interfaces and functions. The user will be guided from first starting a Unigraphics session to creating models and designs that have various applications. Each chapter has components explained with the help of various dialog boxes and screen images. These components are later used in the assembly modeling, machining and finite element analysis. These models of components are available online to download and use. We first released the Tutorial for Version 18 and later updated for NX-2. This write-up is further updated to Unigraphics NX-3.

If you have any questions or comments about this tutorial, please email Parthiban Delli at pdwt5@umr.edu. The Models and all the versions of the Tutorial are available at http://web.umr.edu/~mleu/.
CHAPTER 1 - INTRODUCTION

The modern manufacturing environment can be characterized by the paradigm of delivering products of increasing variety, smaller lots and higher quality in the context of increasing global competition. Industries cannot survive worldwide competition unless they introduce new products with better quality, at lower costs and with shorter lead time. There is intensified international competition and decreased availability of skilled labor. With dramatic changes in computing power and wider availability of software tools for design and production, engineers are now using Computer Aided Design (CAD), Computer Aided Manufacturing (CAM) and Computer Aided Engineering (CAE) systems to automate their design and production processes. These technologies are now used everyday for engineering tasks. Below is a brief description of how CAD, CAM, and CAE technologies are used during the product realization process.

1.1 PRODUCT REALIZATION PROCESS

The product realization process can be divided into design and manufacturing. The design process starts with identification of a new design need that is identified after the marketing personnel gets feedback from customers’ demands. Once the relevant design information is gathered, design specifications are formulated. Next, a feasibility study is done with relevant design information. Detailed design and analyses then follow. Detailed design includes design conceptualization, prospective product drawings, sketches and geometric modeling. Analysis includes stress analysis, interference checking, kinematics analysis, mass property calculations and tolerance analysis, and design optimization. The quality of the results obtained from these activities is directly related to the quality of the analysis.

The manufacturing process starts with the shop-floor activities beginning from production planning, which uses the drawings from the design process and ends with the actual product. Process planning includes activities like production plan, material orders, and machine selection. There are varied tasks like procurement of new tools, NC programming and quality checks at various stages during production. Process planning includes planning for all these activities as well. Parts that pass the quality control inspections are assembled functionally tested, packaged, labeled, and shipped to customers.
A diagram representing the Product Realization Process [1] is shown below. ([1] – CAD/CAM, by Ibrahim Zeid)

1.2 BRIEF HISTORY OF CAD/CAM DEVELOPMENT

The roots of today’s CAD/CAM technologies go back to the beginning of civilization when graphics communication was recognized by engineers in ancient Egypt. Orthographic projection practiced today was invented around the 1800s. The real development of CAD/CAM systems started in the 1950s. CAD/CAM went through four major phases of development in the last century. The 1950s was known as the era of interactive computer graphics. MIT’s Servo Mechanisms Laboratory demonstrated the concept of numerical control (NC) on a three axis milling machine. Development in this era was slowed down by the shortcomings of computers at the time. During the late 1950s the development of Automatically Programmed Tools (APT) began and General Motors explored the potential of interactive graphics.

The 1960s was the most critical research period for interactive computer graphics. Ivan Sutherland developed a sketchpad system, which demonstrated the possibility of creating
drawings and alterations of objects interactively on a cathode ray tube (CRT). The term CAD started to appear with the word ‘design’ extending beyond basic drafting concepts. General Motors announced their DAC-1 system and Bell Technologies introduced the GRAPHIC 1 remote display system.

During the 1970s, the research efforts of the past decade in computer graphics had begun to be fruitful, and important potential of interactive computer graphics in improving productivity was realized by industry, government and academia. The 1970s is characterized as the golden era for computer drafting and the beginning of ad hoc instrumental design applications. National Computer Graphics Association (NCGA) was formed and Initial Graphics Exchange Specification (IGES) was initiated.

In the 1980s new theories and algorithms evolved and integration of various elements of design and manufacturing was developed. The major research and development focus was to expand CAD/CAM systems beyond three-dimensional geometric designs and provide more engineering applications.

In the present day, CAD/CAM development is focused on efficient and fast integration and automation of various elements of design and manufacturing along with the development of new algorithms. There are many commercial CAD/CAM packages available for direct usages that are user-friendly and very proficient.

Here are some of the commercial packages in the present market.

- AutoCAD and Mechanical Desktop are some low end CAD softwares which are mainly used for 2D modeling and drawing.

- Unicraphics, Pro-E, Mechanical Desktop, CATIA and Euclid are higher order modeling and designing software that are costlier but more efficient. The other capabilities of these softwares are manufacturing and analysis.

- Ansys, Abaqus, Nastran, Fluent and CFX are packages mainly used for analysis of structures and fluids. Different software are used for different proposes. For example, Fluent is used for fluids and Ansys is used for structures.

- Alibre, Cyber-Cut and CollabCAD are the latest CAD/CAM softwares which focus on collaborative design. Collaborative design is computer aided designing for multiple users working at the same time.
1.3 DEFINITION OF CAD/CAM/CAE

1.3.1 Computer Aided Design – CAD

CAD is technology concerned with using computer systems to assist in the creation, modification, analysis, and optimization of a design. Any computer program that embodies computer graphics and an application program facilitating engineering functions in design process can be classified as CAD software.

The most basic role of CAD is to define the geometry of design – a mechanical part, a product assembly, an architectural structure, an electronic circuit, a building layout, etc. The greatest benefits of CAD systems are that they can save considerable time and reduce errors caused by otherwise having to redefine the geometry of the design from scratch every time it is needed.

1.3.2 Computer Aided Manufacturing – CAM

CAM technology involves computer systems that plan, manage, and control the manufacturing operations through computer interface with the plant’s production resources.

One of the most important areas of CAM is numerical control (NC). This is the technique of using programmed instructions to control a machine tool that cuts, mills, grinds, punches or turns raw stock into a finished part. Another significant CAM function is in the programming of robots. Process planning is also a target of computer automation.

1.3.3 Computer Aided Engineering – CAE

CAE technology uses a computer system to analyze the functions of a CAD-created product, allowing designers to simulate and study how the product will behave so that the design can be refined and optimized.

CAE tools are available for a number of different types of analyses. For example, kinematic analysis programs can be used to determine motion paths and linkage velocities in mechanisms. Dynamic analysis programs can be used to determine loads and displacements in complex assemblies such as automobiles. One of the most popular methods of analyses is using a Finite Element Method (FEM). This approach can be used to determine stress, deformation, heat transfer, magnetic field distribution, fluid flow, and other continuous field problems that are often too tough to solve with any other approach.
1.4 SCOPE OF THIS TUTORIAL

This tutorial is written for students and engineers who are interested in learning how to use Unigraphics for designing mechanical components and assemblies. Learning to use this software will also be valuable for learning how to use other CAD systems such as PRO-E and CATIA.

This tutorial provides a step-by-step approach for learning Unigraphics. The topics include Getting Started with Unigraphics, Form Features, Feature Operations, Drafting, Sketching, Free Form Features, Assembly Modeling, and Manufacturing.

Chapter 1 gives the overview of CAD/CAM/CAE. Here, the product realization cycle is discussed along with the history of CAD/CAM/CAE and the definitions of each.

Chapter 2 includes the Unigraphics essentials from starting a session with Windows to getting familiar with the Unigraphics-NX3 layout by practicing basic functions such as Print, Save, and Exit. It also gives a brief description of the Coordinate System, Layers, various tool boxes and other important commands, which will be used in later chapters.

The actual designing and modeling of parts begins with chapter 3. It describes different features such as reference features, swept features and primitive features and how these features are used to create designs.

Chapter 4 is a continuation of chapter 3 where various kinds of operations are performed on features. The different kinds of operations include Trim, Blend, Boolean operations and many more.

You will learn how to create a drawing from a part model in chapter 5. In this chapter, we demonstrate how to create a drawing by adding views, dimensioning the part drawings, and modifying various attributes in the drawing such as text size, arrow size and tolerance.

Chapter 6 presents the concept of sketching. It describes how to create sketches and to give geometric and dimensional constraints. This chapter is very important since present-day components are very complex in geometry and difficult to model with only basic features.

Chapter 7 introduces free-form modeling. The method of modeling curves and smooth surfaces will be demonstrated.

Chapter 8 teaches the concepts of Assembly Modeling and its terminologies. It describes Top-Down modeling and Bottom-Up modeling. We will use Bottom-Up modeling to assemble components into a product.

Chapter 9 will be a real-time experience of implementing a designed model into a manufacturing environment for machining. This chapter deals with generation, verification and simulation of Toolpaths to create CNC (Computer Numerical Codes) to produce the designed parts from Vertical Machining Centers.
Chapter 10 is capsulated into a brief introduction to Structures Module available in Unigraphics for the Finite Element Modeling and Analysis.

The examples and exercise problems which are used in each chapter are so designed that they will be finally assembled in the chapter. Due to this distinctive feature, you should save all the models that you have generated in each chapter.
CHAPTER 2 - GETTING STARTED IN UNIGRAPHICS

We begin with starting a Unigraphics session. This chapter will provide the basics required to use any CAD/CAM package. You will learn the preliminary steps to start, to understand and to use the package for modeling, drafting, etc. It contains four sub-sections a) Opening a Unigraphics session, b) Printing, saving, and closing part files, c) Becoming familiar with the NX3 user interface d) Using layers and e) Understanding important commands & dialogs.

2.1 OPENING UNIGRAPHICS AND FILES

2.1.1 Open Unigraphics

➢ From the Windows desktop screen, click on Start → Programs → NX 3.0 → NX 3.0

The main Unigraphics Screen will open. This is the Gateway of UNIGRAPHICS-NX3.
The Unigraphics-NX3 blank screen looks like the figure shown below. There will be different tips displayed on the screen about the special features of the current version.

![Unigraphics-NX3 blank screen](image)

### 2.1.2 Open a New File

- On the menu bar found at the top-left of the screen, click **FILE**

The File drop-down menu is displayed.

The *New* and *Open* options are at the top of this menu. They are both darkened which means you can select them. The options that have been grayed out cannot be selected.

- Click **NEW**
This will open a new session, asking for the location and the name of the new file to be created. You can also select the units (inches or millimeters) of the working environment by clicking on the radio buttons on the bottom left corner. The default is **mm**, but most of Tutorials are designed in **inches**. So always be sure to select inches before creating a new **prt** file unless otherwise specified.

2.1.3 Open a Part File

- Click **FILE → OPEN**

You can also click the Open icon from the Standard toolbar at the top of the screen.

The Open Part File dialog will appear. You can see the preview of the files on the right side of the window.
2.2 PRINTING, SAVING AND CLOSING PART FILES

2.2.1 Print a Unigraphics Image

➢ Click FILE → PRINT

You can also click the Print icon on the Standard toolbar. The following figure shows the Print dialog box. Here, you can choose which printer to use or specify the number of copies to be printed.
2.2.2 Save Part Files

It is important to save your work very frequently. If for some reason, Unigraphics shuts down and the work is not saved, all the work will be lost.

➢ Choose FILE

On the File drop-down menu, there are three different options to save a file.

- SAVE will save the part with the same name.
- SAVE WORK PART ONLY will save the active part on the screen.
- SAVE AS will save the part using a different name.
- SAVE ALL will save all the opened part files with their existing names.
- SAVE BOOKMARK will save photoshot of the current model on the screen as JPEG files and bookmarks.

2.2.3 Close Part Files

➢ Choose FILE → CLOSE

If you close a file, the file will be cleared from working memory and any changes that are not saved, will be lost. Therefore, try to remember to select SAVE AND CLOSE or SAVE ALL AND CLOSE or SAVE ALL AND EXIT.
2.2.4 Exit an Unigraphics Session

➢ Choose FILE → EXIT

➢ Since we are not ready to exit Unigraphics, click NO

If you have files open and have made changes to them without saving, the following message will appear.

Select NO, save the files and then exit.

2.2.5 Simultaneously Saving All Parts and Exiting

A second way to exit Unigraphics allows you to both save all files and exit the program.

➢ Choose FILE → CLOSE → SAVE ALL and EXIT.

The Save and Exit warning dialog window is shown below.

2.3 UNIGRAPHICS-NX3 INTERFACE:

The user interface of Unigraphics is made simple through the use of icons. Most of commands can be executed by navigating the mouse around the screen and clicking on the icons. The keyboard entries are mostly used for entering values and naming files.
2.3.1 Mouse Functionality

It is highly recommended to use a three-button mouse or a scroll-mouse while working with Unigraphics-NX3. The power of mouse buttons and their primary functions are discussed below.

2.3.1.1 Left Mouse Button

The MB1 or left mouse button is used to select icons, menu headings, and other entities on the graphic screen. Double clicking MB1 on any feature will automatically open the edit Dialog box.

2.3.1.2 Middle Mouse Button:

The MB2 or middle mouse button or the scroll button is used to rotate the object by pressing, holding and dragging. It can be used for pan and Zoom options with other mouse buttons or key buttons. If it is a scroll button, the object can be zoomed in and out by scrolling. Just clicking the MB2 will execute the OK command if any pop-up window or dialog box is open.

2.3.1.3 Right Mouse Button:

MB3 or Right Mouse Button is used to access the user interface pop-up menus. You can access the subsequent options that pop up depending on the selection mode. Clicking on MB3 when a feature is selected will give the options related to that feature (Object/Action Menu).

Clicking and holding the button will display a set of icons around the feature. These icons are concerned to the possible commands that can be applied to the feature.
Clicking MB3 on graphics screen will pop up the View menu options.

2.3.1.4 Mouse Functions

The following is the illustration of the mouse buttons used for rotating, panning and zooming in or out on the graphic screen. Besides using these different combinations of mouse buttons, these commands can also be performed by icons in the Toolbar.

**Rotate:**

- Press and hold the middle mouse button (or scroll button) and drag around the screen to view the model in the direction you want. The model can also be rotated about a single axis. To rotate about the axis horizontal to the screen, place the mouse pointer near the right edge of the graphic screen and rotate. Similarly for the vertical axis and the axis perpendicular to the screen, click at the bottom edge and top edge of the screen respectively and rotate.
- If you keep pressing the MB2 at the same position for a couple of seconds, it will fix the point of rotation (a green + symbol appears) and you can drag around the object to view.
2.3.2 Unigraphics Gateway

The following figure shows the typical layout of the Unigraphics window when a file is opened. This is the Gateway of Unigraphics from where you can select any module to work on such as
modeling, manufacturing, etc. It has to be noted that these toolbars may not be exactly on the same position of the screen as shown below. They might be placed at some other place of the screen. Look out for the same set of icons.

2.3.2.1 Functions of each Gateway zone

**Title Bar:**
The Title Bar displays the following information for the current part file.

- The name of the current displayed part
- The name of the current work part
- If the work part is read only
- If the work part has been modified since it was last saved

**Menu Bar:**
The Menu bar is the horizontal menu of options displayed at the top of the main window directly below the title bar. Menu bar options are called menu titles and each corresponds to a Unigraphics NX functional category. Clicking on a menu title leads to a drop-down menu of choices.
**Tool Bar:**
A Toolbar is a row of icons that you can use to activate standard Unigraphics NX menu items. Unigraphics NX comes with a large selection of toolbars.

**Resource Bar:**
The Resource Bar features icons for a number of pages in one place using very little user interface space. Unigraphics NX places all navigator windows in the Resource Bar, as well as the History Palette, a training page, and the Web Browser. The Resource Bar is located on the right side of the Unigraphics NX window. You can dock and undock the resource bars by clicking on the pin icon on the top left of the resource window.

**Cue Line:**
The Cue Line is shown at the bottom or top of the main Unigraphics NX window. The Cue Line displays prompt messages that indicate the next action that needs to be taken.

**Status Line:**
The Status Line, located to the right of the Cue area, displays information messages about the current options or the most recently completed function.

**Progress Meter:**
The Progress Meter is displayed in the Cue Line when the system performs a time-consuming operation such as loading a large assembly. The meter shows the percentage of the operation that has been completed. When the operation is finished, the system displays the next appropriate cue.

**2.3.2.2 Model or Part Navigator**

The Part Navigator provides a visual representation of the parent-child relationships of features in the work part in a separate window in a tree type format. It shows all the primitives, entities used during modeling. It allows you to perform various editing actions on those features. For example, you can use the Part Navigator to suppress or unsuppress the features or change their parameters or positioning dimensions. Removing the green tick mark will ‘Suppress’ the feature. The software will give a warning if the parent child relationship is broken by suppressing any particular feature.

The Part Navigator is available for all Unigraphics NX applications and not just for modeling. However, you can only perform feature editing operations when you are in the Modeling module. Editing a feature in the Part Navigator will automatically update the model.
2.3.2.3 History:

The History Palette provides fast access to recently opened files or other palette entries. It can be used to reload parts that have been recently worked on or to repeatedly add a small set of palette items to a model.

The History Palette remembers the last palette options that were used and the state of the session when it was closed. Unigraphics NX stores the palettes that were loaded into a session and restores them in the next session. The system does not clean up the History Palette when parts are moved.

To re-use a part, drag and drop it from the History Palette to the Graphics Window. To reload a part, click on a saved session bookmark.

2.3.3 Geometry Selection

Geometry Selection properties are very advanced in Unigraphics-NX3. You can filter the selection method, which facilitates easy selection of the geometry in a close cluster. In addition, you can perform any of the feature operation options that Unigraphics intelligently provides depending on the selected entity.

The Mouse cursor in the Graphics screen will normally be in the shape of a circle as shown in the figure. Selection of items can be based on the degree of the entity like, selection of Geometric entities, Features and Components. The selection method can be opted by choosing one of the icons in the Selection Toolbar.

Feature Selection:

Clicking on the icon as shown in the figure below will let you select the features in the part file. It will not select the basic entities like edges, faces etc.
Besides that, the filtering of the features can be further narrowed down by selecting one of the desired options in the drop-down menu as shown in the figure below. For example, selecting CURVE from the option will highlight only the curves in the screen. The default is ANY.

**General Object Selection:**

Clicking on the icon as shown in the below figure will let you select the general object entities displayed in the screen.

Again, the filtering of the entities can be further narrowed down by selecting one of the desired options in the drop-down menu as shown in the figure below. The default is ANY.
If you want to select any geometric entity, feature, or component, then navigate the mouse cursor closer to the entity until it becomes highlighted with a magenta color and click the left mouse button.

If you want to select an entity that is hidden behind the displayed geometry, then place the mouse cursor roughly on that area of the screen such that cursor ball occupies a portion of the hidden geometry projected on the screen. After a couple of seconds, the ball cursor turns into a plus symbol as shown in the figure.

Click the left mouse button to get a ‘Selection Confirmation’ dialog box as shown in the following figure. This dialog boxes consists of the list of entities captured within the ball of the cursor. The entities are arranged in ascending order of the degree of the entity. For example, edges and vertices are assigned lower numbers while solid faces are given higher numbers. By moving the cursor on the numbers displayed, Unigraphics will highlight the corresponding entity on the screen magenta. For example, in the figure below, the face on the top is assigned the number ‘5’. Likewise the hidden entities will also be allotted with a number in the list. You can browse through the numbers and click on the number that corresponds to the desired object or feature.
2.3.4 User Preferences

Use Preferences are to define the display parameters of new objects, names, layouts, and views. You can set the layer, color, font, and width of created objects. You can also design layouts and views, control the display of object and view names and borders, change the size of the selection ball, specify the selection rectangle method, set chaining tolerance and method, and design and activate a grid. Changes that you make using the Preferences menu override any counterpart customer defaults for the same functions.

➢ Choose PREFERENCES on the Menu bar to find the various options available

User Interface

The User Interface option customizes how Unigraphics NX works and interacts to specifications you set. You can control the location, size and visibility status of the main window, graphics display, and Information window. You can set the number of decimal places (precision) that the system uses for both input text fields and data displayed in the Information window. You can also specify a full or small dialog for file selection. You can also set macro options and enable a confirmation dialog for Undo operations.

➢ Choose PREFERENCES→USER INTERFACE to find the options in the dialog box.
Visualization

This dialog controls attributes that affect the display in the graphics window. Some attributes are associated with the part or with particular views in the part. The settings for these attributes are saved in the part file. For many of these attributes, when a new part or view is created, the setting is initialized to a value specified in the customer defaults file.

Other attributes are associated with the session and apply to all parts in the session. The settings of some of these attributes are saved from session to session in the registry. For some session attributes, the setting can be initialized to the value specified by customer default, an environment variable.

- Choose PREFERENCES → VISUALIZATION to find the options in the dialog box.
- Change the tab buttons find the options available under each command.
- Choose COLOR PALLETETAB and Click on EDIT BACKGROUND to get another pop up Dialog box. You can change your background color whatever you want.

The background color refers to the color of the background of the graphics window. Unigraphics NX supports graduated backgrounds for all display modes. You can select background colors for Shaded or Wireframe displays. The background can be Plain or Graduated. Valid options for all background colors are 0 to 255.
**Edit Object Display**

Object Display option is used to modify the layer, color, font, width, grid count, translucency, and shading status of existing objects.

- **Right Click** on the solid body in Part Navigator and Choose Edit Display.

This will pop up a dialog window **EDIT OBJECT DISPLAY**. Change and observe the Color and Translucency of the solid object. This is not just limited to solid objects. You can also apply this setting to individual entities of the solid. For example you can click on any particular surface of the solid and apply the Display settings.

![Edit Object Display Window](image)
2.4 COORDINATE SYSTEMS

2.4.1 Absolute Coordinate System

The Absolute Coordinate System is the coordinate system from which all objects are referenced. Because this coordinate system is a fixed coordinate system, the locations and orientations of every object in Unigraphics modeling space are related back to its origin. The Absolute Coordinate System (or “Absolute CSYS”) also provides a common frame of reference between part files. An absolute position at X=1, Y=1, and Z=1 in one part file is the same location in any other part file.

2.4.2 Work Coordinate System

The Work Coordinate System (WCS) is what you will use for construction when you want to determine orientations and angles of features. The axes of the WCS are denoted XC, YC, and ZC. (The “C” stands for “current”.)

It is possible to have multiple coordinate systems in a part file, but only one of them can be the work coordinate system.

2.4.3 Existing Coordinate Systems

You can create an “existing coordinate system” (CSYS) whenever you need to return to a specific location and orientation in modeling space.

2.4.4 Move the WCS

Here, you will learn how to translate and rotate the WCS.

2.4.4.1 Translate the WCS

This procedure will move the WCS origin to any point you specify, but the orientation (direction of the axes) of the WCS will remain the same.

➢ Choose FORMAT →WCS → ORIGIN

The Point Constructor dialog is displayed in the figure.

You can specify points by either choosing one of the icons at the top of the dialog, or by entering the X-Y-Z coordinates in the XC, YC, and ZC fields.
Most of the work will be in relation to the working coordinate system rather than the absolute coordinate system. The default is the WCS.

The default action button is Inferred Point. The name of the active icon appears above the top row of action buttons.

2.4.4.2 Rotate the WCS

You can also rotate the WCS around one of its axes.

➢ Choose **FORMAT → WCS → ROTATE**

The Rotate WCS dialog is shown on the right side. The dialog shows six different ways to rotate the WCS around an axis. These rotation procedures follow the right-hand rule of rotation.

2.4.4.3 Save the Current Location and Orientation of the WCS

You can save the current location and orientation of the WCS to use as a permanent coordinate system.

➢ Choose **FORMAT → WCS → SAVE**

2.5 USING LAYERS

2.5.1 Layer Control

With Unigraphics, you can control whether objects are visible or selectable by using layers. A layer is a system-defined attribute that all objects in Unigraphics must have, such as color, font, and width. A layer may be thought of as a partition in the part file that objects reside in, or ON for the purpose of organization. There are 256 usable layers in Unigraphics, one of which is always the Work Layer. Any of the 256 layers can be assigned to one of four classifications of status:

- Work
- Selectable
- Visible Only
- Invisible
The Work Layer is the layer that objects are created ON and is always visible and selectable while it remains the Work Layer. Layer I is the default Work Layer when starting a new part file. When the Work Layer is changed to another layer, the previous Work Layer automatically becomes Selectable and can then be assigned a status of Visible Only or Invisible.

The number of objects on one layer is not limited. You have the freedom to choose which layers you want to create objects on and what the status will be. However, it should be mentioned that the use of company standards in regards to layers would be advantageous.

To assign a status to a layer or layers,

- Choose **FORMAT → LAYER SETTINGS**

### 2.5.2 Commands in Layers

We will follow simple steps to practice the commands in Layers. First we will create two objects (Solids) by the method as follows. The details of Surface and Solid Modeling will be discussed in the next chapter. The solids that we draw here are only for practice in this chapter.

- Choose **FILE → NEW**

- Name the file and choose a folder in which to save it. Make sure you selected the units to be inches in the radio button.

- Click **OK**

- Choose **APPLICATION → MODELING** or Click on the Icon on the Application Toolbar

- Choose **INSERT → DESIGN FEATURE → CYLINDER**
Choose **DIAMETER, HEIGHT**

The Vector Constructor dialog will appear. The default direction will be in Z direction.

- Click **OK** on the Vector Constructor

Then the next dialog will ask for diameter and height.

- Type in 4 inches for the diameter and 8 inches for the height.

- Click **OK**

The next window is the Point Constructor for you to determine the location of the cylinder. The default location will be the origin (0, 0, 0) on the WCS.

- Click **OK**

- Click **CANCEL** on any other window that pops up.

The screen will now look like the following figure.
➤ Click the right button of the mouse on the screen
➤ Choose ORIENT VIEW → TRIMETRIC

➤ If the solid is in wire-frame, right-click on the screen.
➤ Choose DISPLAY MODE → SHADED

You can also click on the Shaded icon in the toolbar.

Now you will be able to see a solid cylinder.

Now let us practice some Layer Commands.
➤ Choose FORMAT → MOVE TO LAYER

You are asked to select a surface or solid.
➢ Move the cursor on to the cylinder and click on it so that it becomes highlighted.

➢ Click on the tick mark  

You will get the following pop window.

➢ In the Destination Layer or Category space at the top of the window, type in 15.

➢ Choose APPLY → CANCEL

The Cylinder has now gone to the 15th layer. It can no longer be seen in Layer 1.

➢ To see the cylinder, click FORMAT → LAYER SETTINGS

➢ Double-click on ‘15’

The status of the 15th layer will become SELECTABLE.
Click OK

The cylinder will again be seen on the screen. Save the file as we will be using it later in the tutorial.

2.6 IMPORTANT COMMANDS/DIALOGS

In this section, you will learn some important commands and dialogs which will be useful during modeling and sketching.

2.6.1 Toolbars

Toolbars contain icons, which serve as shortcuts for many Unigraphics functions. The following figure shows the main Toolbar items normally displayed. However, you can find many more icons for different feature commands depending on the module and how you wish to customize them.

Right Click anywhere on the existing toolbars to get a long list of Toolbars. You can bring in any of the toolbars in the list to the screen.

The list of toolbars you can see in the default option is Standard, View, Visualization, Selection, Object Display, etc. Normally, the default setting should be sufficient for most operations but during certain operations, you might need additional toolbars. If you want to add buttons pertaining to the commands and toolbars,
Click on the Pull-down arrow on any of the Toolbar and choose **ADD OR REMOVE BUTTONS**.

Choose **CUSTOMIZE**.

This will pop up a Customize dialog window with all the Toolbars under ‘Toolbar’ Tab and commands pertaining to each Toolbar under ‘Commands’ tab. You can check all the toolbars that you wish to be displayed.

### 2.6.2 Transform Functions

- Open the file that you created in section 2.5.2 with the cylinder.
- **Click on** EDIT → **TRANSFORM**

Here, we have to choose an entity such as a solid body or curves or a sketch.

- Click on the cylinder so that it becomes highlighted.
- **Click on** the tick mark

Unigraphics-NX3 for Engineering Design  
University of Missouri - Rolla  
37
This dialogue box allows you perform many functions like translating, scaling, and mirroring part of a model.

- Click on **TRANSLATE**

Another dialogue box opens with options as shown in the figure.

- **TO A POINT** – This option allows you to move the center of the cylinder to any destination point on the X-Y-Z axis that you determine. The coordinates are based on the WCS.

- **DELTA** – This option moves the selected option in the X-Y-Z direction by the distance that you enter.

- Click on **DELTA**

- Type in 5 in the **DXC** box.

Then the next dialog box will open. Here you have many options like Move, Copy, etc.

- Select **MOVE**

The cylinder will move in the X-direction by a distance of 5 inches.

- Click **CANCEL**

As you can see, we have moved the cylinder in the X-direction. Similarly, we can also copy the cylinder by a certain distance or to a certain location. These are the basic commands that you will need initially.
CHAPTER 3 - FORM FEATURES

This chapter will discuss the basics of Form features in Unigraphics: what is a feature, what are the different types of features, what primitives are and how to model features in Unigraphics. It will give you the preliminary steps to start, understand and use features for modeling. Unlike NX2, all the Form features are not arranged in the same location in NX3. They are categorized in different menus based on the functions and ease of identification.

3.1 OVERVIEW

Features are objects that are associatively defined by one or more parents and that retain within the model the order of its creation and modification, thus capturing its history. Parents can be geometrical objects or numerical variables. Features include primitive, surface and solid objects, and certain wire frame objects (such as curves and associative trim and bridge curves). For example, some common features include blocks, cylinders, cones, spheres, extruded bodies, and revolved bodies.

3.2 TYPES OF FEATURES

There are six types of Form features: Reference features, Swept features, Remove features, User-defined features, Extract features and Primitives. As mentioned before Form features are not arranged under the same menu INSERT option in Menubar. However they are grouped together in the same Toolbar called FORM FEATURES.
➤ Click **INSERT** on the Menu Bar.

As you can see, the marked menus in the figure on the right side contain the commands of Form Features.

The Icons of the Form features are grouped in the Form Feature as shown below. You can choose the icons that you use frequently.

➤ Click on the drop down arrow in Form Feature Toolbar

➤ Choose **ADD OR REMOVE BUTTONS**

➤ Choose **FORM FEATURE**
**Reference Features**
These let you create reference planes or reference axes. These references can assist you in creating features on cylinders, cones, spheres and revolved solid bodies.

- Click on **INSERT → DATUM/POINT**
Reference Features include,
  - Datum Plane
  - Datum Axis
  - Datum CSYS
  - Point
  - Point Set
  - Plane

**Swept Features**
These let you create bodies by extruding or revolving sketch geometry. Swept Features include,

- Extruded Body
- Revolved Body
- Sweep along Guide
- Tube
- Styled Sweep

- Click on **INSERT → DESIGN FEATURE** for Extrude and Revolve
- Click on **INSERT → SWEEP** for rest of the options.

**Remove Features**
They let you create bodies by removing solid part from other parts.

- Click on **INSERT → DESIGN FEATURE**
Remove Features include,
  - Hole
  - Boss
  - Pocket
  - Pad
  - Slot
  - Groove
**User-Defined features**
These allow you to create your own form features to automate commonly used design elements. You can use user-defined features to extend the range and power of the built-in form features.

- Click on **INSERT → DESIGN FEATURE → USER DEFINED**

**Extract Features**

These features let you create bodies by extracting curves, faces and regions. These features are widely spaced under different menus. Extract Features include,

- Extract
- Sheet from curves
- Bounded plane
- Thicken Sheet
- Sheet to Solid Assistant

- Click on **INSERT → ASSOCIATIVE COPY → EXTRACT** for Extract options.

- Click on **INSERT → OFFSET/SCALE** for Thicken Sheet and Sheets to Solid Assistant.

- Click on **INSERT → SURFACE** for Bounded Plane and Sheet from curves.

**Primitives**

They let you create solid bodies in the form of generic building shapes. Primitives include,

- Block
- Cylinder
- Cone
- Sphere

Primitives are the primary entities. Hence we will begin with a short description of primitives and then proceed to modeling various objects.
3.3 PRIMITIVES

Primitive features are base features from which many other features are created. The basic primitives are blocks, cylinders, cones and spheres. Primitives are non-associative which means they are not associated to the geometry used to create them. The parameters of these primitive objects can be changed.

Now let’s start modeling some basic models.

3.3.1 Model a Block

- Create a new file and name it Arborpress_plate.prt.
- Choose APPLICATION → MODELING

Now let’s model a plate.

- Choose INSERT → DESIGN FEATURE → BLOCK or Click on this icon in the Form feature Toolbar.

The Block window will then appear. There are three ways to create a block primitive.

- Origin, Edge Lengths,
- Height, Two Points
- Two Diagonal Points

These icons are located at the top of the window. We will use the Origin, Edge Lengths method which should be the default option.

Now, we will choose the origin using the Point Constructor.

- Click on the POINT CONSTRUCTOR icon located in the Utility Toolbar at the bottom of the screen as shown in the following figure.
The Point Constructor box will open. The XC, YC, ZC points should have a default value of 0.

- Click OK

The Block window will reappear.

- Type in the following dimensions.
  - Length (XC) = 65 inches
  - Width (YC) = 85 inches
  - Height (ZC) = 20 inches

- Click OK

- If you do not see anything on the screen, right-click and select FIT. You can also press <Ctrl> + F.

- Right-click on the screen and click on ORIENT VIEW → TRIMETRIC

You should be able to see the complete plate solid model. Save and close the part file.
3.3.2 Model a Shaft

After modeling a very basic block, we will now model a shaft having two cylinders and one cone joined together.

- Create a new file and save it as **Impeller_shaft.prt**.
- Choose **APPLICATION → MODELING**
- Choose **INSERT → DESIGN FEATURE → CYLINDER**

There are two ways to create a cylinder.

- Diameter, Height
- Height, Arc

- **Select DIAMETER, HEIGHT**

A Vector Constructor dialog box now opens as shown below.

- Click on the ZC Axis icon which should be the default. This will set the I and J vectors to be 0 and the K vector to be 1
- Leave the other options as default and click **OK**

- In the next Cylinder window, type in the following values as
  - Diameter = 4 inches
  - Height = 18 inches
- Click **OK**

The next window is the Point Constructor to determine the origin of the cylinder.

- Click **RESET** to set all the XC, YC, and ZC coordinates to be 0
- Click **OK**

- **Click CANCEL** on any other windows that appear.
➢ Right-click on the screen, choose **ORIENT VIEW → ISOMETRIC** and make the cylinder solid.
You can change the color of the solid body and the background as mentioned in the Chapter 2.3.4. The cylinder will look as shown below.

![Cylinder Diagram]

Now we will create a cone at one end of the cylinder.

➢ Choose **INSERT → DESIGN FEATURE → CONE**

There are various ways to create a cone.

- Diameters, Height
- Diameters, Half Angle
- Base Diameter, Height, Half Angle
- Top Diameter, Height, Half Angle
- Two Coaxial Arcs

➢ Select **DIAMETERS, HEIGHT**

The next window will be the Vector Constructor.

➢ Choose the ZC Axis icon so the vector is pointing in the positive Z direction. You can also change the vector coordinates so that the I and J vectors are 0 and the K vector is +1

➢ Click **OK**

➢ In the cone window, type in the following values:
  - Base diameter = 4 inches
  - Top Diameter = 6 inches
  - Height = 10 inches

➢ Click **OK**
The Point Constructor window will appear next.

- Choose the Arc/Ellipse/Sphere Center icon on the dialog box and click on the top circular edge of the cylinder.

(Or)

- For the Base Point coordinates, type in the following values:
  
  \[
  \begin{align*}
  XC &= 0 \\
  YC &= 0 \\
  ZC &= 18
  \end{align*}
  \]

- Click OK

- On the Boolean Operation window, choose UNITE

Now the cone will appear on top of the cylinder.

- Click CANCEL on any other windows

- Press <Ctrl> + F or right-click and select FIT.

The shaft is shown below.

![Shaft Image]

Now we will create one more cylinder on top of the cone.

- Repeat the same procedure as before to create a cylinder. The vector should be pointing in the positive Z direction. The cylinder should have a diameter of 6 inches and a height of 20 inches. On the Point Constructor window, again click on the Center icon and construct it at the center point of the base of the cone.
The complete shaft will look as shown below. Remember to save the model.

3.4 REFERENCE FEATURES

3.4.1 Datum Plane

Datum Planes are reference features that can be used as construction tools in building a model. Datum planes can assist in creating features on cylinders, cones, spheres, and revolved solid bodies. Datum planes can also aid in creating features at angles other than normal to the faces of the target solid.

We will follow some simple steps to practice reference features.

First we will create a Datum Plane that is offset from a face.

- Open the model Arborpress_plate.prt.
- Choose APPLICATION → MODELING
- Choose INSERT → DATUM/POINT → DATUM PLANE
The Datum Plane dialog displays like the figure shown below.

- Click on the Datum Plane Dialog icon, the first one on the left.

The Datum Plane window, shown on the right side, allows you to choose the method of selection. However, Unigraphics is smart enough to judge the method depending on the entity you select, if you keep in inferred option.

- Click on the top surface of the block so that it becomes highlighted.

The vector displays the positive offset direction that the datum plane will be created in. If you had selected the bottom face, the vector would have pointed downward, away from the solid.

- Insert the Offset value as 15 in the dialog box and Choose **APPLY** on the Datum Plane Window.

The offset Datum Plane will look as below.

- If you don’t see the complete model and plane, right-click and select FIT.

There are several other methods to create Datum Planes, such as creating a Datum Plane through Three Points, Creating a Centered Datum Plane and Creating a Datum Plane on a Curve and so on.
3.4.2 Datum Axis

In this part, you are going to create a Datum Axis. A Datum Axis is a reference feature that can be used to create datum planes, revolved features, extruded bodies, etc.

Datum axes can be created either relative to another object or as a fixed axis (i.e., not referencing, and not constrained by, other geometric objects).

- Choose **INSERT → DATUM/POINT → DATUM AXIS**

The Datum Axis dialogue box is shown as below.

- Select the Datum Axis Dialog icon on the left.

The next window allows you to choose the method of selecting the axis. However, Unigraphics can judge which method to use depending on the entity you select.

There are various ways to make a datum axis. They include Point and Direction, Two Points, Two Planes, etc.

- Select the Two Points icon at the top of the Datum Axis window.

- Select the two points on the block as shown in the figure on the right.

- Click **OK**
The Datum Axis will be a diagonal as shown below.

3.5 SWEPT FEATURES

3.5.1 Extruded Body

The Extruded Body option lets you create a solid or sheet body by sweeping generator geometry (curves, solid faces, solid edges, sheet body) in a linear direction for a specified distance.

In this part, we will extrude a line into a rectangular block as follows.

➢ Create a new part file and save it as Arborpress_rack.prt.

➢ Choose APPLICATION → MODELING

➢ Right-click, then choose ORIENT VIEW → ISOMETRIC

To learn the extrude command, we will create a 2D rectangle first and then extrude this rectangle to form a solid.

➢ Choose INSERT → CURVES → BASIC CURVES

You can also choose the Curve icon in the toolbar.
The Basic Curves window will open as below.

The default curve is **LINE**.

- In the drop down menu for **Point Method**, choose **POINT CONSTRUCTOR**.

- Type in the following XYZ coordinate values for each individual point.

<table>
<thead>
<tr>
<th>XC</th>
<th>YC</th>
<th>ZC</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>0.00</td>
<td>25.00</td>
<td>0.00</td>
</tr>
<tr>
<td>240.00</td>
<td>25.00</td>
<td>0.00</td>
</tr>
<tr>
<td>240.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
<tr>
<td>0.00</td>
<td>0.00</td>
<td>0.00</td>
</tr>
</tbody>
</table>

- Click **OK** after each set of coordinates. *Note: Enter X, Y and Z value and choose OK every time to enter a point.*

- Click **CANCEL** after all the points have been entered

- Right-click on the screen and choose **FIT**

You should see the rectangle as seen below.
Now we will extrude the rectangle to form a solid.

- Choose **INSERT → DESIGN FEATURE → EXTRUDE**

A Toolbar pops up with list of icons concerned to Extruded Body.

- Choose on Extrude Body icon on the left of the Toolbar as shown in the figure below.

This will pop a Dialog box ‘**Extrude**’.

- In the Extruded Body window, type in the following values.
  
  **Start** = 0  
  **End** = 20

- Click on all four lines in a cyclic manner. You can find the preview on the Graphic screen as you proceed with the selection of the lines.

- Click **OK**
The extruded body will appear as shown below. Remember to save your work.

Similar to the Extrude function, we can also perform functions such as Revolve, Tube, etc.

3.6 REMOVE FEATURES

There are various features that allow you to remove rather than create part of the design. They are illustrated as follows.

**Hole:**
This option lets you create simple, counterbored and countersunk holes on solid bodies.

**Boss**
This option lets you create a simple cylindrical protrusion on a planar face or datum plane.

**Pocket**
You can use the Pocket option to create a cavity in an existing body. It can be cylindrical or rectangular.

**Pad**
Use the Pad option to create a rectangular on an existing solid body.
**Slot**
This option lets you create a passage through or into a solid body in the shape of a straight slot. An automatic subtract is performed on the current target solid. It can be rectangular, T-slot, U-Slot, Ball end or Dovetail.

**Groove**
This option lets you create a groove in a solid body, as if a form tool moved inward (from an external placement face) or outward (from an internal placement face) on a rotating part, as with a turning operation.

We will now learn how to create holes.

- Open the file **Arborpress_plate**.
- Choose **APPLICATION → MODELING**
- Choose **INSERT → DESIGN FEATURES → HOLE**
- In the Hole window, enter the following values;
  Diameter = 8 inches
  Depth = 25 inches
  Tip Angle = 118 inches
- Now select the top face of the plate.
- Click **OK**

- Select **PERPENDICULAR** option from the Positioning dialogue box

- First click on the edge as highlighted in the following figure.

You will get a ‘**Current Expression**’ Text box.

- Insert value of Current Expression as 10 for the distance.
Choose **APPLY**

Similarly,

- Select **PERPENDICULAR** option from the Positioning dialogue box once again.
- Click on the other edge and enter the value **11.25** for the distance

**Click → OK**

The hole will be formed as shown below.
Follow the same procedure to make five other holes in the block at the coordinates given below.

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
<th>Z</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>11.25</td>
<td>10.00</td>
<td>0.00</td>
<td>Done</td>
</tr>
<tr>
<td>32.50</td>
<td>23.50</td>
<td>0.00</td>
<td></td>
</tr>
<tr>
<td>53.75</td>
<td>10.00</td>
<td>0.00</td>
<td></td>
</tr>
<tr>
<td>11.25</td>
<td>75.00</td>
<td>0.00</td>
<td></td>
</tr>
<tr>
<td>32.50</td>
<td>61.50</td>
<td>0.00</td>
<td></td>
</tr>
<tr>
<td>53.75</td>
<td>75.00</td>
<td>0.00</td>
<td></td>
</tr>
</tbody>
</table>

The final plate will be as shown below.

We have now completed the basic form features. The user-defined form features are advanced options in which new form features are added into the library.

### 3.7 EXERCISE - MODEL A WASHER

As an exercise, model a washer as shown in the figure.

The washer has the following dimensions.  
Outer diameter = 0.73 inches  
Inner diameter = 0.281 inches  
The thickness of the washer can vary within realistic limits. For practice take the value to be 0.05 inches.
CHAPTER 4 – FEATURE OPERATIONS

Feature operations are the continuation of form features. In this chapter you will learn some of the functions that can be applied to the faces and edges of a solid body. These include taper, edge blend, face blend, chamfer, trim body and so on. After explaining the feature operations, the Chapter will take you to some walk-through examples. As mentioned in the beginning of the Chapter 3, even Feature operations are categorized under different option menus, unlike Unigraphics-NX2. So you cannot find a single menu ‘Feature Operation’ under the INSERT menu, but in Toolbar, they are grouped under FEATURE OPERATION.

4.1 OVERVIEW

Feature operations are performed on the basic form features to smooth corners, create tapers, and unite or subtract certain solids from other solids. Some of the feature operations are shown below.

Let us see the different types of feature operation commands in Unigraphics and the function of each command.

4.2 TYPES OF FEATURE OPERATIONS

The features operations used in Unigraphics include Taper, Edge blend, Face blend, Soft blend, Chamfer, Hollow, Thread, Instance, Sew, and Patch. Let us see some of the important commands in details.
**Taper**

The Taper command lets you taper features, faces, or bodies relative to a specified vector. You can create variable tapers, fixed angle tapers, and split-line tapers.

**INSERT → DETAIL FEATURE → TAPER**

**Edge Blend**

An Edge Blend is a radius blend that is tangent to the blended faces. This feature modifies a solid body by rounding selected edges.

**INSERT → DETAIL FEATURE → EDGE BLEND**

**Chamfer**

The chamfer function operates very similarly to the blend function by adding or subtracting material relative to whether the edge is an outside chamfer or an inside chamfer.

**INSERT → DETAIL FEATURE → CHAMFER**
**Thread**

Threads can only be created on cylindrical faces. The Thread function lets you create symbolic or detailed threads (on solid bodies) that are right or left handed, external or internal, parametric, and associative threads on cylindrical faces such as holes, bosses, or cylinders.

**INSERT → DESIGN FEATURE → TAPER**

![Thread Diagram](image)

**Trim Body**

A solid body can be trimmed by a sheet body or a datum plane. You can use the Trim Body function to trim a solid body with a sheet body and at the same time retain parameters and associativity.

**INSERT → TRIM → TRIM**

**Split Body**

A solid body can be split into two just like trimming it. It can be done by a plane or a sheet body.

**INSERT → TRIM → SPLIT**

![Split Body Diagram](image)
Instance:

A Design feature or a Detail feature can be made into dependent copies in a form of array. It can be Rectangular or Circular array or just a Mirror. This is a very helpful feature that saves plenty of time and modeling.

**INSERT → ASSOCIATIVE COPY → INSTANCE**

![3x4 Rectangular Instance](image1)

![10 Instances at 36 degrees of rotation each](image2)

Boolean Operations

Boolean operations are,
- Unite,
- Subtract and
- Intersect

These options can be used when two or more solid bodies share the same model space in the part file.

**INSERT → COMBINE BODIES**

Consider two solids given. The block and the cylinder are next to each other as shown below.
**Unite:**
The unite command basically adds the Tool body with the Target body. For the above example the output will be as follows if Unite option is used.

![Unite Diagram](image)

**Subtract:**
When using the subtract option, the Tool body is subtracted from the Target body. That is the volume of the Whole Tool body will be evacuated from the Target body. The following would be the output if the rectangle is used as Target and the cylinder as Tool. Unlike the Unite option, the output will be different if it is inversed.

![Subtract Diagram](image)

**Intersect:**
This command leaves the volume that is common to both the target and tool bodies. The output is shown below.

![Intersect Diagram](image)
4.3 FEATURE OPERATIONS ON MODELS

In the previous chapter we dealt with form features. In this chapter, we see how primitives and basic form features are converted into complex models by using feature operations.

4.3.1 Model a Hexagonal Screw

- Create a new file and save it as Impeller_hexa-bolt.
- Choose APPLICATION → MODELING
- Choose INSERT → DESIGN FEATURE → CYLINDER
- The cylinder should be pointing in the Z-direction with the following dimensions.
  - Diameter = 0.25 inches
  - Height = 1.5 inches
- Place the center of the cylinder at the origin.

Now create a small step cylinder on top of the existing cylinder.
- The dimensions of this cylinder are,
  - Diameter = 0.387 inches
  - Height = 0.0156 inches
- On the Point Constructor window, click the Center icon at the top
- Then click on the top face of the existing cylinder as shown in the following figure.
On the Boolean Operation window, choose **UNITE**

The two cylinders should look like the figure shown below.

Save the model.

Next we will create a hexagon for the head of the bolt.

- Choose **INSERT → CURVE → POLYGON**
- On the Polygon window, type in 6 for the number of sides and click **OK**.

There are three ways to draw the polygon.

- Inscribed Radius
- Side of Polygon
- Circumscribed Radius

- Choose **SIDE OF POLYGON**
- On the next window, enter the following dimensions.
  Side = 0.246 inches
  Orientation Angle = 0.00 inches
- Click **OK**

- On the Point Constructor window, again choose the Center icon
- Click on the top face of the last cylinder drawn
The polygon will be seen as shown below. If the model is not in wireframe, click on the Wireframe icon in the View Toolbar.

Now we will extrude this polygon.

- Choose **INSERT → DESIGN FEATURE → EXTRUDE**
- Click on all six lines of the hexagon to choose the surface that are needed to be extruded.
- Enter the End Distance as 0.1876 inches.

The model looks like the following after extrusion

- On top of the cylinder that has a diameter of 0.387 inches, insert another cylinder with the following dimensions.
  - Diameter = 0.387 inches
  - Height = 0.1875 inches
You will only be able to see this cylinder when the model is in wireframe since the cylinder is inside the hexagon head. The model will look like the following.

We will now use the feature operation Trim.

- Choose **INSERT → TRIM → TRIM**
- When the Trim Body window opens, select the hexagon head
- Click **OK**
On the next window, choose **DEFINE SPHERE**

- Choose **CENTER, DIAMETER**
- Enter the value of the diameter as 0.55 inches and click OK.
- On the Point Constructor window, choose the Center icon
- Select the bottom of the last cylinder drawn, which is inside the hexagon head and has a diameter of 0.387 inches and a height of 0.1875 inches as shown below

- Click **ACCEPT DEFAULT DIRECTION**

This will give you the hexagonal head as shown below.
Now we will do threading to the hexagonal bolt.

- Choose **INSERT → DESIGN FEATURE → THREAD**

Here you will see the threading dialog box as shown below.

There are two main options in Threading: 1) Symbolic and 2) Detailed.
- Click on the **DETAILED** radio button
- Click on the bolt shaft, the long cylinder below the hexagon head

Once the shaft is selected, all the values will be displayed in the Thread dialog box. Keep all these default values.
- Click **OK**

The hexagon bolt should now look like the following. Save the model.

4.3.2 Model an L-Bar

Here we will make use of some feature operations such as edge blend, chamfer, and subtract.
- Create a new file and save it as **Arborpress_L-bar**.
- Choose **APPLICATION → MODELING**
- Choose **INSERT → DESIGN FEATURE → BLOCK**
- Create a block with the following dimensions.
  
  - Length = 65 inches
  - Width = 65 inches
  - Height = 285 inches
➢ Place the block at the origin.

The block will look as shown below.

![Block at Origin](image1)

➢ Create a second block also placed at the origin with the following dimensions.
  - Length = 182 inches
  - Width = 65 inches
  - Height = 85 inches

You may have to use the Point Constructor icon on the bottom toolbar to place the block at the origin. There will be two blocks as seen below.

![Two Blocks](image2)

We have to move the second block to the top of the first block.

➢ Click **EDIT → TRANSFORM**

➢ Select the second block that you inserted which is longer in the X-direction
➢ Translate the block in the Z-direction by a distance of 200.

➢ Click **MOVE**

After transformation, it will look like the following.

Now we will create a hole. There are many ways to create a hole. We will do so by first creating a cylinder and then using the Subtract function.

➢ Choose **INSERT → DESIGN FEATURE → CYLINDER**

As a shortcut, you can also click on the Cylinder icon.

➢ On the Vector Constructor window, select the YC Axis icon.

➢ The cylinder should have the following dimensions. 
  Diameter = 35 inches
  Height = 100 inches

➢ On the Point Constructor window, enter the following values.

<table>
<thead>
<tr>
<th>Axes</th>
<th>XC</th>
<th>YC</th>
<th>ZC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>182</td>
<td>65</td>
<td>85</td>
</tr>
</tbody>
</table>

➢ On the Boolean Operation widow, choose **SUBTRACT**

➢ Select the horizontal block at the top as shown in the figure on the right side.
The hole should look like the one in the figure. Save your model.

Now we will create another cylinder and subtract it from the upper block.

- Insert a cylinder pointing in the positive Y-direction with the following dimensions.
  - Diameter = 66 inches
  - Height = 20 inches

- On the Point Constructor window, enter the following values.
  - Axes: Values
    - XC: 130
    - YC: 22.5
    - ZC: 242

- Subtract this cylinder from the same block as before.

The wireframe model will be seen as shown.
Now we will create a block.

➢ Choose INSERT → DESIGN FEATURE → BLOCK
➢ Create a block with the following dimensions.
   - Length = 25 inches
   - Width = 20 inches
   - Height = 150 inches
➢ On the Point Constructor window, enter the following values.

<table>
<thead>
<tr>
<th>Axes Values</th>
<th>XC</th>
<th>YC</th>
<th>ZC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Values</td>
<td>157</td>
<td>22.5</td>
<td>180</td>
</tr>
</tbody>
</table>

The model will look like the following figure.

![Block with dimensions](image)

Now we will subtract this block from the block with the hole.

➢ Choose INSERT → COMBINE BODIES → SUBTRACT
➢ Click on the block with the two holes.
➢ When the Class Selection window appears, select the newly created block
➢ Click OK

The model will be seen as shown below.

![Model with subtraction](image)
Now we will use the Blend function in feature operations. In order to do so, we must first unite the two blocks.

- Choose INSERT → COMBINE BODIES → UNITE
- Click on the two blocks and click OK.

The two blocks are now combined into one solid model.

- Choose INSERT → DETAIL FEATURE → EDGE BLEND
- Change the Default Radius to 60.
- Select the edge that the arrow is pointing to in the figure.

- Click on the Tick mark.

The blend will look as shown below.
Repeat the same procedure to blend the inner edge of the block. This time, the default radius should be changed to 30.

The blended figure is shown below. Remember to save the model.

We will now make 4 holes in the model. You can create these holes by using Hole-option illustrated in the Chapter-3, however for the practice of Feature operations follow the below procedures.

- Insert 4 cylinders individually. They should be pointing in the X-direction and have the following dimensions.
  - Diameter = 8 inches
  - Height = 20 inches

They should be constructed at the following point coordinates.

<table>
<thead>
<tr>
<th></th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>162</td>
<td>162</td>
<td>162</td>
<td>162</td>
</tr>
<tr>
<td>Y</td>
<td>11.25</td>
<td>11.25</td>
<td>53.75</td>
<td>53.75</td>
</tr>
<tr>
<td>Z</td>
<td>210</td>
<td>275</td>
<td>210</td>
<td>275</td>
</tr>
</tbody>
</table>

- **SUBTRACT** these cylinders from the top block.
The last operation on this model is to create a block and subtract it from the top block.

- Create a block with the following dimensions.
  - Length = 60 inches
  - Width = 20 inches
  - Height = 66 inches

- Enter the following values on the Point Constructor.

<table>
<thead>
<tr>
<th>Axes</th>
<th>XC</th>
<th>YC</th>
<th>ZC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>130</td>
<td>22.5</td>
<td>209.5</td>
</tr>
</tbody>
</table>

- After creating the block, subtract this block from the block at the top by first selecting the original block and then clicking on the newly created block.

The final figure will look like this.

4.3.3 Model a Hexagonal Nut

- Create a new file and save it as Impeller_hexa-nut.

- Choose APPLICATION → MODELING,

- INSERT → CURVE → POLYGON

- Create a hexagon with each side measuring 0.28685 inches and constructed at the origin.

- Extrude the hexagon by 0.125 inches.
The figure of the model is shown below.

We will now use the Trim command.

- Choose **INSERT → TRIM → TRIM**
- Select the model we just created
- Choose **DEFINE SPHERE → CENTER, DIAMETER**
- Enter the diameter value 0.57 inches.
- Enter the Point Constructor values as follows.

<table>
<thead>
<tr>
<th>Axes</th>
<th>XC</th>
<th>YC</th>
<th>ZC</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>0.0</td>
<td>0.0</td>
<td>0.125</td>
</tr>
</tbody>
</table>

- Click **ACCEPT DEFAULT DIRECTION**

The trimmed model will look like the following.

We will now use a Mirror command.

- Choose **EDIT → TRANSFORM**
- Select the model
- Click **MIRROR THROUGH A PLANE**
- Click **THREE PONTS** option.
Here click 3 points on the flat side of the model as shown. Be careful to select only the points and not the edges.

Click on COPY

You will get the following model.

Choose INSERT → COMBINE BODIES → UNITE

Select the two halves and unite them

Insert a cylinder with the vector pointing in the Z-direction and with the following dimensions.
- Diameter = 0.25 inches
- Height = 1 inch
Center the cylinder on the origin.
Subtract this cylinder from the hexagon nut.

Now, we will chamfer the inside edges of the nut.

Choose INSERT → DETAIL FEATURE → CHAMFER

In the Chamfer window, select SINGLE OFFSET
Select the two inner edges as shown below and click OK.

Next enter the Chamfer Offset as 0.0436 inches and click OK.

You will see the chamfer on the nut. Save the model.

4.3.4 Model a Rack with Instances

In this part, we will practice to create instances.

- Open the file Arborpress_rack.prt.
- Choose APPLICATION → MODELING
- Choose INSERT → DESIGN FEATURE → POCKET
- Choose RECTANGULAR in the pop up Selection Window.

Click on the top surface of the rack as shown in the figure for the placement surface.
Click on the edge as shown in the figure for the horizontal reference.

This will pop up the parameters window. Enter the values of parameters as shown in the figure and choose **OK**. Choose **Wireframe** option in the Display mode for more clarity.

- When the Positioning window pops up, choose the **PERPENDICULAR** option as shown in the figure below.
- Then Click on the edge on the solid and then click on the blue dotted line as shown below.
➢ Enter the expression value as 37.8 and Choose OK.

Once again pick the PERPENDICULAR option and this choose the other set of the edges along the Y-Axis, as shown in the figure below.

➢ Enter the expression value as 10 and Choose OK twice. Choose Cancel.

The model will now look as follows.

Let us create the instances of the slot as the teeth of the Rack to be meshed with pinion.

➢ Choose INSERT → ASSOCIATIVE COPY → INSTANCE

➢ Choose RECTANGULAR ARRAY from the selection tabs.
➢ Choose **RECTANGULAR POCKET** from the Instance Dialog box as shown in the figure below. Choose **OK**.

![Instance Dialog](image)

➢ Enter the values in the parameter window as shown in the figure. This creates 19 copies including the original at the offset distance of 9.4 inches. Choose **OK**.

![Enter parameters](image)

➢ Choose **YES**

➢ Choose **CANCEL**

The model of the Rack will look as the one shown in the figure.
Create a Hole of Diameter 10 inches and depth 20 inches at the centre of the Rectangular cross section. Move the curves that have been used for extrusion, to some other layer. The final model is shown below.
4.4 EXERCISE - MODEL A CIRCULAR BASE

As an exercise, model a circle base as shown below using the following dimensions:

Outer diameter = 120 inches
Distance of 3 small slots = 17 inches
Distance of the large slot = 30 inches
Diameter of the central rod = 4 inches and length = 30 inches
Length of slots may vary.

Top and Front view dimensions are shown in the figure below.
CHAPTER 5 – DRAFTING

The Unigraphics Drafting application lets you create drawings, views, geometry, dimensions, and drafting annotations necessary for the completion of a drawing. The goal of this chapter is to give the designer/draftsman enough knowledge of drafting tools to create a basic drawing of their design. The drafting application supports the drafting of engineering models in accordance with ANSI standards. After explaining the basics of the drafting application, we will go through a step-by-step approach for drafting some of our earlier models.

5.1 OVERVIEW

The Drafting application is based on creating views from a solid model as illustrated below. Drafting makes it easy to quickly create a drawing with orthographic views, section views, imported view, auxiliary views, dimensions and other annotations.

Some of the useful features of Drafting application are:
1) After you choose the first view, other orthographic views can be added and aligned by the click of some buttons.
2) Each view is associated directly with the solid. Thus when the solid is changed, the drawing will be updated directly including the views and dimensions.
3) Drafting annotations (dimensions, labels, and symbols with leaders) are placed directly on the drawing and are also updated automatically when the solid is changed.

We will see how views are created and annotations are used and modified in the step-by-step examples.
5.2 DRAFTING OF MODELS

We will draft some models that have already been drawn. We will go through the drafting options step-by-step to make them easier to understand.

5.2.1 Drafting

- Open the file Arborpress_rack.prt.
- Choose APPLICATION → DRAFTING

When you first open the Drafting module a window will pop-up asking for inputs like name of the drawing sheet, specifications of the drawing sheet, the angle of projection and units.

- In the drop-down menu on the Drafting window, select sheet B which has dimensions 11 X 17, change the denominator of the Scale value as 25 and click OK.
This will open the drafting option and the following screen will be seen as below.

Choose INSERT → VIEW → BASE VIEW
You can find a Dialog box with the options of the view and the scale of the view, as shown in the figure.

Choose the View to be ‘FRONT’.

You can find the Front View projection on the screen. You can move the Mouse cursor on the screen and click on the place where you want the view.

Once the first view is fixed on the Sheet, Unigraphics will automatically provide the user with real time Orthographic projected views with respect to the first view created. You can find the views keep changing as move the cursor around the first view (FRONT View).
The following are some snap shots of the views seen at different location of the mouse cursor.

If you want to add any orthographic views after closing this file or changing to other command modes,

- Choose **INSERT → VIEW → PROJECTED VIEW**

Now create an orthographic projected view as shown below and click on the screen at the desired position.

- Click on the Icon to choose other view as the Base View for further Projections.
Click on the view that is created later (Front Elevation View) as shown in the figure and move the cursor to the left side and click there to get Right side view.

Press <Esc> key on the Keyboard to get out of the View creation. The Drawing sheet will now look as shown in the following figure.

Before creating the dimensions, let us remove the borders in each view as it adds confusion with the entity lines.

- Choose **PREFERENCES → DRAFTING**

This will pop a Dialog window ‘DRAFTING PREFERENCES’.

- Click on the **VIEW** tab button
- Remove the Tick mark on the Display Borders
Now you can find the drawing views without Borders as shown below.

5.2.2 Dimensioning

Now we have to create the dimensions for these views. The dimensions can be inserted by either of the two ways.

1) Choose **INSERT → DIMENSION** or

2) Click on the Dimension Toolbar as shown in the following figure

➢ Choose **INSERT → DIMENSION → INFERRED**

The following two option boxes will pop up. The icons on this toolbar are helpful for changing the properties of the dimensions. Close the ‘Annotation Placement’ box.
The first icon allows you to change the properties of the dimension lines, values, and arrows.

The second icon allows you to change the number of significant digits given in the dimension. For example selecting 2 will display the dimension as “240.00” while selecting 3 will display “240.000”.
The third icon lists different styles of displaying the Nominal dimension and Tolerances.

The next icon is the annotation editor, which you can use to edit the dimension value.
The last icon in the option bar resets these properties to default settings. Now we will create the first dimension.

- On the First view (FRONT View) that you created, click on the top left corner of the rack and then on the top right corner.

The dimension that represents the distance between these points will appear.

You can determine the position of the dimension by moving the mouse.

- To set the dimension onto the drawing sheet, place the dimension well above the view as shown and click the left mouse button.
Even after creating the dimension, you can edit the properties of the dimensions.

- Right-click on the dimension you just created and Choose **STYLE**.

- Increase the Character Size to 0.2 and click **OK**.

- Give dimensions to all other views as shown in the following figure.
5.2.3 Sectional View

Let us create a Sectional View for the same to show the depth and profile of the hole.

- Choose **INSERT → VIEW → SECTION VIEW**

Click on the bottom View for the Base View as Shown in the figure. This will show a Phantom line with two Arrow marks for the direction of the Section plane. Click on the middle of the View. This will fix the position of the sectional line (Section Plane).

Now move the cursor around the view to get the direction of the Plane of section. Keep the arrow pointing vertically upwards and drag the sectional view to the bottom of the base View.

Adjust the dimension positions. The Final Drawing sheet should look like the one shown in the following figure.
5.2.4 Drafting and Dimensioning of an Impeller hexagonal bolt

- Open the model `Impeller_hexa-bolt.prt`.
- Choose APPLICATION → DRAFTING
- On the New Drawing Sheet window, select sheet **E-34 X 44** and change the Numerator Scale value to 8.0.
- Choose INSERT → VIEW → BASE VIEW
- Add the FRONT (not TOP) view by repeating the same procedure as in the last example.
- Add the Orthographic Views, including the side view and plan view.
- Choose PREFERENCES → DRAFTING
- Uncheck the box next to Display Borders under View Tab.
- Choose PREFERENCES → VISUALIZATION

The screen will have 3 views as follows.
There are always the hidden lines which are not seen. To see the hidden lines

- Choose **PREFERENCES → VIEW** or

- Select the views, right-click and choose **STYLE** as shown below.

![View Style Window](image)

This will pop-up a window with various options pertaining to the views.

- Click on the **Hidden lines** tab

- Change **INVISIBLE to DASHED LINES** as shown below

![Hidden Lines Settings](image)

You can see the hidden lines as shown below.
Now we will proceed to dimensioning.

- Choose **INSERT → DIMENSIONS → VERTICAL**
- Give vertical dimensions to all the distances shown below.

Now we have to give the dimensions of the bolt head.

- Choose **INSERT → DIMENSIONS → PARALLEL**
- Give the two dimensions to the bolt head as shown in the figure.

For the threading, we will use a leader line.
Click on the GDT Symbol icon as shown in the Tool bar.

In the Annotation Editor window that opens, enter the following text exactly as shown. You can find Ø and the degree symbol on the Drafting Symbols tab.

Right Hand Ø 0.20 X 1.5
Pitch 0.05, Angle 60°

Click on the threaded shaft in the side view, hold the mouse and drag the Leader line next to the view. Let go of the mouse and click again to place the text.

Close the Annotation Editor.

Since the height of the Lettering is small, we will enlarge the character size.

Right-click on the Leader and select STYLE

Click on the Lettering tab

Increase the Character Size to make the leader legible.

Now we will add additional dimensions and views.

Choose INSERT → DIMENSIONS → DIAMETER

Click the circle of the bolt in the top view to give the diameter dimension

Click INSERT → VIEW → BASE VIEW

Select the TFR-ISO view and place the view somewhere on the screen. The final drawing is shown below. Remember to save.
5.3 EXERCISE - DRAFTING AND DIMENSIONING OF A CIRCULAR BASE

As an exercise, perform drafting and give dimensions to the circle base that you modeled in Exercise 4.4. The model of the part is displayed below.
CHAPTER 6 – SKETCHING

In this chapter, you will learn how to create and edit sketches in Unigraphics. Sketching in NX3 version is much more user-friendly compared to its older versions. Up to this point, the only way you have learned to create a new model is by creating and operating form features. In this second method of modeling, you will first create a sketch and then extrude, revolve or sweep the sketch to create solids. Many complex shapes that are otherwise very difficult to model using primitives or other form features can be easily drawn by sketching. In this chapter, we will see some concepts of sketching and then proceed to sketch and model some parts.

6.1 OVERVIEW

A Unigraphics sketch is a named set of curves joined in a string that when swept forms a solid. The sketch represents the outer boundary of that part. The curves are created on a plane in the sketcher. These curves are drawn without any exact dimensions in the beginning. There are two kinds of constraints:
1) Geometric constraints and
2) Dimensional constraints.

These will be discussed in detail later.

These are the different ways that you can use sketches:

- A sketch can be revolved

![Sketch](image-url)
• A sketch can be extruded

• A sketch can be swept along a guide (line)

The advantages of sketching over using primitives are,

- a) The curves used to create the profile outline are very flexible and can be used to model unusual shapes.
- b) The curves are parametric, hence associative and they are easily changed or removed.
- c) If the plane in which the sketch is changed, the sketch will be changed accordingly.
- d) Sketches are useful when you want to be able to easily control an outline of a feature, especially if it may need to be changed in the future. Sketches can be edited very quickly and easily.

6.2 SKETCHING FOR CREATING MODELS

In earlier chapters we dealt with the form features and their feature operations. In this chapter, we model complex models by using sketching.
6.2.1 Model an Arbor press Base

- Create a new file and save it as Arborpress_base.prt.
- Choose APPLICATION → MODELING
- Choose INSERT → SKETCH or click on the Sketch icon on the Toolbar.

The main screen will change in sketching mode. The XY plane is highlighted as the default sketching plane. However, you can choose to sketch on another plane. If there are any solid features created in the model beforehand, any of the flat surfaces can also be used as a sketching plane.

This is the basic sketch window. It can be divided into various parts which have been labeled.
You can change the name of the sketch in the box next to the Finish Flag.

Now, let us choose the XC-YC plane.

- Select the XC-YC Plane icon as shown in the figure
- Click on the green check mark to confirm the Sketching plane

The sketch plane will appear and the X-Y directions will be marked. This is 2D sketching.
6.2.1.1 Sketch Curve Toolbar:

This toolbar contains icons for creating basic curves and spline curves, editing, extending, trimming, filleting etc. Each type of curve will have different methods of selection. Let us discuss the most frequently used options.

**Profile:**
This option creates both straight lines as well as arcs depending on the icon you select in the pop-up toolbar. You can pick the points by using the coordinate system or by entering the length and angle of the line as shown in the following figures.

**Line:**
This option will selectively create only straight lines.

**Arc:**
This option creates arcs by either of two methods. The first option creates arc with three sequential points as shown below.

The second option creates the arc with a center point, radius and sweep angle or by center point with a start and end point. The illustration is shown below.

**Circle:**
Creating as circle is similar to creating an arc, except that the circle is closed unlike an arc.
**Quick Trim:**
This trims the extending curves from the points of intersection of the curves. This option reads every entity by splitting them if they are intersected by another and erases the portion selected.

**Studio Spline:**
You can create basic splines (B-spline and Bezier) with poles or through points with the desired degree of the curve. The spline will be discussed in detail in the next chapter (Freeform Features).

![Studio Spline](image)

### 6.2.1.2 Constraints Toolbar:

All the curves are created by means of picking points. For example a straight line is created with two points. In a 2-D environment, any point will have two degrees of freedom, one along X and another along Y. The number of points depends on the type of curve being created. So a curve entity will have twice the number of degrees of freedom than the number of points it comprises. These degrees of freedom can be removed by creating a constraint with a fixed entity. In fact it is recommended to remove all these degrees of freedom by relating the entities directly or indirectly to the fixed entities. It can be done by giving dimensions or geometric properties like Parallel, Perpendicular etc.

(Note: These degrees of freedom will be displayed in orange arrows. All these arrows should be removed by applying the constraints to follow a disciplined modeling.)

**Dimensional Constraint:**
The degrees of freedom can be eliminated by giving dimensions with fixed entities like axes, planes, the coordinate system or any existing solid geometries created in the model. These dimensions can be linear, radial, angular etc. You can edit the dimensional values at anytime during sketching by double-clicking on the dimension.

**Geometric Constraints:**
Besides the dimensional constraints, there are some geometric constraints that can be given to eliminate the degrees of freedom. They include parallel, perpendicular, collinear, concentric, horizontal, vertical, equal length, etc. The software has the capability to find the set of possible constraints for the selected entities.
**Show all Constraints:**
Clicking this icon will show all the options pertaining to the entities in that particular sketch in white.

**Show/Remove Constraints:**
This window lists all the constraints and types of constraints pertaining to any entity selected. You can delete any of the listed constraints or change the sequence of the constraints.

### 6.2.1.3 Sketcher Toolbar:

Besides being able to change the name of the Sketch, the sketcher toolbar also has some other highly useful features mentioned below.

**Orient View to Sketch:**
If the model file is rotated during the process of sketching, click on this icon to view the sketch on a plane parallel to the screen.

**Reattach Sketch:**
This function allows you to reattach the sketch to the desired plane without recreating all the curves, dimensions, and constraints.

**Update Model:**
When you make changes in a sketch, click on this icon to see the effects of those changes without exiting the Sketch mode.

Now we will draw curves using the options discussed above.

- Click on the Profile icon. Click on Zoom In/Out icon on the main toolbar located at the top of the screen (you can also use scroll to zoom). Look at the XC and YC values and Zoom the Sketching screen such that a sketch of 190X90 can be approximately accommodated with the graphic screen. There is no harm in leaving it as such but Zooming to approximate size will make it easier to edit the dimensions of our sketch later on.
Draw a figure similar to the one shown below. While making continuous sketch click on the Line icon on the Profile toolbar to create straight lines and the Arc icon to make the semicircle. (Look at the size of the XY plane in the figure. Use that perspective for the approximate zooming.)

Once sketching is complete, we will constrain the sketch. It is better to apply the geometric constraints before giving the dimensional constraints.

Click on the Constraints icon in the side toolbar

You will be able to see all the degrees of freedom on the screen represented by orange arrows.
➢ Click on the two top horizontal lines shown in the figure

The Constraint toolbar should automatically pop-up.

➢ Select the Collinear icon from the toolbar

![Collinear Diagram]

➢ Click the same two lines again and select the Equal Length icon

![Equal Length Diagram]

➢ Select the two slanted lines and make them equal in length

![Equal Length Diagram]
Similarly select the two long vertical lines and make them equal in length.

Select the bottom two horizontal lines and make them collinear and then click on the same lines and make them equal in length.

If you DO NOT find the two Blue circles (Tangent Constraints) near the semicircle as shown in the figure, follow the below steps. Otherwise you can ignore it.
Select the circular arc and one of the two vertical lines connected to its endpoints.

Select the Tangent icon.

If the arc and line are already tangent to each other, the icon will be grayed out. If this is the case click **EDIT → SELECTION → DESELECT ALL**. Repeat the same procedure for the arc and the other vertical line.

So far we have given constraints that relate the sketched entities to each other. We can also make constraints between an entity in the sketch and the datum or fixed reference.

As an example, we will place the center of the arc at the origin. We can use the two default X and Y axes as a datum reference.

Select the Y-axis and then the center of the arc which is marked by the intersection of the yellow arrows. The center of the arc will be marked by a red asterisk once it has been selected.

Click the Point on Curve icon.
➢ Repeat the same procedure to place the center of the arc on the X-axis.

So far we have created all the geometric constraints. Now we have to create the dimensional constraints. You will find that as we add on dimensions, the degrees of freedom represented by the yellow arrows will disappear.

Unigraphics will not allow duplication of dimensions. This is why it is better to apply the geometry constraints first. If there is any conflict between the dimension and geometric constraints, those entities will be highlighted in yellow.

➢ Choose the Inferred Dimensions icon in the Constraints toolbar

➢ Add on all the dimensions as shown in the following figure.

For example, to create a dimension for the top two corners, you may have to click on the arrow next to the Inferred Dimensions icon and click on the Horizontal icon. Then click somewhere near the top of the two diagonal lines to select them. While dimensioning, if you find the dimensions illegible,

➢ Choose PREFERENCES → SKETCH

In the pop up window, change the Text height to 4 as shown in the figure.
Do not worry about editing the dimensions now. Check if the orange arrows are disappearing.

Now edit all the dimension values by double-clicking on each dimension one by one. It is highly recommended to start editing from the biggest dimension first and move to the smaller dimensions. Edit the values as shown in the figure below.
➢ Click on the **Finish flag** on the top left corner of the screen when you are finished.

➢ Click on the sketch and right-click

➢ Click **EXTRUDED BODY**

➢ Extrude this sketch in the Z-direction by 60 inches.

➢ Then create a hole with a diameter of 4 inches and a height of 30 inches at the point (0, 35, 0) from the WCS.
The final figure is shown below.

6.2.2 Model an Impeller Lower Casing

- Create a new file and save it as Impeller_lower-casing.prt.
- Choose APPLICATION → MODELING
- Click on INSERT → SKETCH
- Set the sketching plane as the XC-YC plane.
- Click on the Profile icon and draw the following curve.
Click **INSERT → DATUM/POINT → POINT**

Create a point at the origin (0, 0, 0).

Next, we will constrain the curve.

- Click on the Constraints icon
- Select the point at the origin and click on the Fixed icon
- Make all of the curve-lines and curve-curve joints tangent.
- Then apply the dimensional constraints as follows.

![Constraints](image)

Choose **EDIT → TRANSFORM**

- Select the Class Selection Icon

![Class Selection Icon](image)
Click on the ‘Type’ button and Click on Curve.

Select all the curves, **TRANSLATE** and **COPY** it in the negative Y direction by 0.5 inch. Then join the end points at the two ends to complete the sketch.

The sketch is ready.

- Click on the Finish Flag.
- Click on **INSERT → DESIGN FEATURE → REVOLVE**
- Click on the CURVE option
➢ Click on the sketch lines one after another in the continuous sequence and Choose OK twice.

➢ Choose AXIS AND ANGLE

➢ Choose the vector to point in the positive X-direction

➢ On the Point Constructor, enter the coordinates (0, 0, 0) so the curve revolves around with respect to the origin

➢ Keep the Start Angle as 0 and enter 180 as the value for the End Angle

➢ Click OK

The solid is seen as below.

Now, we will create edges.

➢ Choose EDIT → TRANSFORM

➢ Select the outer curve as shown in the following figure. Be sure to select all four parts of the curve.
Translate this curve in the Y-direction by -1.5 inches. This is the same as translating it in the negative Y-direction by 1.5 inches.

This will form a curve outside the casing.

Using straight lines from Basic Curves, join this curve with the inside curve of the casing.

It will form a closed chain curve as shown.

Click on **INSERT → DESIGN FEATURE → EXTRUDE**

Select the two curves you just joined together and the two lines at the end that connect them.

Extrude this piece in the negative Z-direction by 0.5 inches.

The final solid will be seen as follows.
We will now use the Mirror option to create an edge on the other side.

- Choose **EDIT → TRANSFORM**

- Select the solid edge as shown.

- Choose **MIRROR THROUGH A PLANE**

- Under Principal Planes, click on the **YC Constant** icon and click **OK**

- Select **COPY**

The edge will be mirrored to the other side as shown below.
We will create an edge at the smaller opening of the casing as shown.

To avoid confusion, we will change the color of the solid.

- Right click on the Solid in the Part Navigator and choose **EDIT DISPLAY**
- On the Edit Object Display window, click on the box next to color and choose a different color. Then click **OK**
- Click on **EDIT → TRANSFORM**
- Copy the straight outer edge on the smaller end of the casing by a distance of -0.5 inches in the X-direction.

- Use Basic Curves to join these two lines and form a rectangle.
- Click on **INSERT → DESIGN FEATURE → REVOLVE**

- Revolve this rectangle in the positive X-direction relative to the origin just like for the casing. The End Angle should be 180.

This will form the edge (in green) as shown below.

- Make the whole object one color

- Then use Feature Operations to unite the pieces to make them one solid.

The lower casing is complete. Save the model.
6.2.3 Model an Impeller

Create a new file and save it as Impeller_impeller.prt.

- Click on APPLICATION → MODELING
- Click on INSERT → SKETCH
- Set the sketching plane as the XC-YC plane
- Click on INSERT → POINT
- Create two points, one at the origin (0, 0, 0) and one at (11.75, 6, 0).
- Click on the Arc icon on the side toolbar and click on the Arc by Center and Endpoints icon in the pop-up toolbar
- Click on the point at the origin and create an arc with a radius of 1.5 similar to the one shown in the figure below.
- Click on the point at (11.75, 6, 0) and create an arc with a radius of 0.5.
- Click on the Arc by 3 Points icon in the pop-up toolbar.
- Select the top endpoints of the two arcs you just created and click somewhere in between to create another arc that connects them. Do the same for the bottom endpoints.
- Click on the Constraints icon in the side toolbar and make sure that all the arcs are tangent to one another at their endpoints.
- Click on the point at the origin and click on the Fixed icon.

The sketch should look like the following.
➢ Then click on the Inferred Dimensions icon

➢ Give the radius dimensions for each arc. Edit dimensions so that the two arcs on the end are 1.5 and 0.5 inches and the two middle arcs are 18 and 15 inches as shown in the figure below.

➢ Select the Parallel dimensioning option from the Dimensions drop-down menu.

➢ Create a dimension giving the distance between the origin point and the other point and edit the distance to be 13.19 inches.

➢ Click on the Finish flag when you’re done.

Now the sketch is ready as shown below.
Now let’s model a cone.

- Choose **INSERT → DESIGN FEATURE → CONE**

- Select **DIAMETERS, HEIGHT**

- Select the –XC Axis icon.

- Enter the following dimensions
  - Base Diameter = 15 inches
  - Top Diameter = 8 inches
  - Height = 16.25 inches

- On the Point Constructor, enter the coordinates (14, 0, 0).

The cone will be seen as shown below.

- Extrude the curve in the Z-direction by 13 inches.

The model will be as follows.
➢ Use Feature Operations to unite the blade and the cone.

Now let’s create 5 instances of this blade to make the impeller blades.

➢ Click on **INSERT → FEATURE OPERATION → INSTANCE**

➢ Select **CIRCULAR ARRAY**

➢ Select **EXTRUDED**

➢ For Number, type in 5 and for Angle, enter 72.

➢ Click **OK**

➢ Select **POINT, DIRECTION**

➢ Select the X Axis direction for the Vector Constructor and the origin for the Point Constructor.

The model will be seen as follows.

Now let’s create two holes in the cone for the shaft and the locking pin. Note that these holes can also be created by **HOLE** option.

➢ Subtract a cylinder with a diameter of 4 inches and a height of 16 inches from the side of the cone with the larger diameter as shown.
➢ Subtract another cylinder with a diameter of 0.275 inches and a height of 0.25 inches from the side of the cone with the smaller diameter.

The final model will look like the following. Save your work.

![Model of Impeller Upper Casing](image)

### 6.3 EXERCISES

**Exercise 1 - Model an Impeller Upper Casing:**

As an exercise, model the upper casing of the Impeller as shown below.

![Impeller Upper Casing Model](image)

The dimensions of the upper casing are same as for the lower casing which is described in the previous exercise in detail. The dimensions for the manhole should be such that impeller blades can be seen and a hand can fit inside to clean the impeller.
Exercise 2 - Modeling a Die-Cavity:

Another exercise is to model the following part to be used for the Chapter 9 Manufacturing Module. Create a new file ‘Die_cavity.prt’ with units in mm not in inches. Create a rectangular Block of 150, 100, 40 along X, Y and Z respectively with the point construction value of (-75,-50,-80) about XC, YC and ZC.

Create and Unite another block over the first one with 100, 80 and 40 along X, Y and Z. and centrally located to the previous block.

Create a sketch as shown below including the spline curve and also add an Axis line. Dotted lines are reference lines. While sketching, create them as normal curves. Then right click on the curves and change display property into Phantom lines (Dashed Dot) lines. Give all the constraints and dimensions as shown in the figure below.

Revolve the curves about the dashed axis as shown above and subtract the cut with start angle and end angle as -45 and 45.
Subtract a block of 70, 50, and 30 to create a huge cavity at the centre. Create and Unite 4 cylinders at the inner corners of the cavity with 20 inches diameter and 15 inches height.

Add edge blends at the corners as shown in the final Model below. Keep the value of blend as 10 radii for outer edges and 5mm radii for the inner edges.
CHAPTER 7 – FREEFORM FEATURE

In this chapter, you will learn how to create freeform models in Unigraphics. Up to this point, you have learned different ways to create models by using form features or by sketching. Freeform are generally in the form of B-surfaces. Because of their construction techniques and design applications, these surfaces are usually stylistic. A few freeform features are shown below.

To create freeform features, you must use or define points, curves, edges of sheets or solids, faces of sheets or solids, or other objects. The following topics cover some, but not all, of the methods that you can use to create freeform features.

7.1 OVERVIEW

7.1.1 Creating Freeform Features from Points

When construction geometry includes only points, you may be able to use one of these three options to build the feature.
Click on **INSERT → SURFACE**

- From Point Cloud - if you have scattered points.
- Through Points - if defined points form a rectangular array passing through them.
- From Poles - if defined points form a rectangular array tangential to the lines passing through them.

7.1.2 Creating Freeform Features from Section Strings

If construction geometry contains strings of connected objects (curves, faces, and edges), you may be able to use one of these two options to build the feature.

Click on **INSERT → MESH SURFACE**

- Ruled - if the two strings are roughly parallel.
- **Through Curves** - if the three or more strings are roughly parallel.

If construction geometry contains one or more strings (curves, faces, edges) that are roughly parallel to each other, and one or more section strings that are roughly perpendicular to the first set of curves, you may be able to use one of these following options to build the feature.

- **Swept** - if at least two sections strings are roughly perpendicular.

- **Through Curve Mesh** - if at least four section strings exist with at least two strings in each direction.
7.1.3 Creating Freeform Features from Faces

If the construction geometry contains a sheet or face, you may be able to use one of the following three options to build the feature.
Click on **INSERT → MESH SURFACE**

- **Offset Surface** - if you have a face to offset.

- **Extension** - if you have a face and edges, edge curves, or curves on the face.

7.2 FREEFORM FEATURE MODELING

Let us do some freeform modeling on structured points, a point cloud, curves and faces. Structured points are a set of point’s defined rows and columns. A point cloud has a set of scattered points that form a cloud.

7.2.1 Modeling with points

Open Unigraphics and open the file `freeform_thrupoints.prt`.

- Choose **APPLICATION → MODELING**.
- Right Click on the Toolbars and Check in **SURFACE** Toolbar.
You will see 7 rows with many points.

- Choose **INSERT → SURFACE → THROUGH POINTS**
- Or
  - Click on the Icon in the Toolbar.

The dialogue box will pop up as shown in the right.

- For Patch Type, select **MULTIPLE**
- For Closed Along, select **NEITHER**

For Row Degree and Column Degree, enter 3.

- Click **OK**

The next dialogue box will be as shown.

- Click **CHAIN FROM ALL**
Select the top starting point and the bottom ending point of the left most row as shown in the following figure.

The first row of points will be highlighted.

Repeat the same procedure to select the first four strings of points. After that, a window should pop up asking if all points are specified or if you want to specify another row.
Select **SPECIFY ANOTHER ROW** until all rows are specified

When all the rows are specified, choose **ALL POINTS SPECIFIED**

Click **CANCEL** on the Through Points window

Click on the Shaded icon 🎨

You will see the surface as shown below. **Do NOT** save these files.
7.2.2 Modeling with a point cloud

Open the file named freeform_cloud.prt.

➢ Choose APPLICATION → MODELING.

The point cloud will be seen as follows.

➢ Choose INSERT → SURFACE → FROM POINT CLOUD or Click on this icon on the Toolbar.

The following dialogue box will appear.
At the bottom of the window, you can see the option **Confirm Upon Apply**. This option lets you view and analyze the feature before you create it.

- Make sure the Confirm Upon Apply box is unchecked
- Select all the points on the screen by dragging a rectangle around them

After you have selected the points, the screen will look like the following.

![Image of selection tool](image)

- On the window, choose **WCS** for the Coordinate System.
  This matches the point cloud coordinate system with original system.
- Under Boundary, choose **MINIMUM BOX**
  This is the boundary for the point cloud.
- Keep the default values for **U and V Degree as 3**
- Click **OK**
- Click the Shaded icon to see the model as a solid
The final sheet will look like the following. Again, do NOT save these files.

7.2.3 Modeling with curves

Open the file named freeform_thruCurves_parameter.prt.

➢ Choose APPLICATION → MODELING

The curves will be seen as follows.

➢ Choose INSERT → MESH SURFACE → THRU CURVES or Click on this Icon on the Toolbar.

The following dialogue box will be seen.

➢ Select the first section string as shown. Be sure to select somewhere on the left side of the arc.
Choose **OK**

A direction vector displays at the end of the string.

Repeat the same procedure to select the remaining strings. Be sure to click **OK** after each selection.

After all five strings have been selected and confirmed, five vectors are displayed.

Choose **OK** to confirm that all strings are selected.
A new Through Curves dialog box is displayed.

- For Patch Type, choose **SINGLE**
- For Alignment, choose **PARAMETER**
- On the bottom, check the box next to **SIMPLE**

When the Simple option is activated, the system tries to build the simplest surface possible and minimize the number of patches.

- Click **OK twice**

The following curved surface will be generated. Again, do not save the file.
7.2.4 Modeling with curves and faces

Open the file named freeform_thru_curves_faces.prt.

- Choose APPLICATION → MODELING

The curve and faces will be seen as follows.

- Choose INSERT → MESH SURFACE → THRU CURVES

- Select the left edge of the top plane as shown below. Make sure to select the object at the location where the arrow points.

- Click OK

- Then click on the curve and click OK

- Similarly, click on the top edge of the other face from left to right as shown below

- Then click OK
➤ Click OK again

The following dialogue box will appear.

Make sure that all the arrows are pointing in the same direction. If not, click CANCEL and reselect the strings.

➤ Under both First Section String and Last Section String, choose CURVATURE

➤ Make sure the box next to Simple is unchecked

➤ Click OK
Then you get a dialog box to select the faces.

- Select the faces as shown below and click OK

- Now select the three faces as shown below and choose OK again.

- Click OK

The final curve will be seen as shown below. Do not save the files.
7.3 EXERCISE - MODEL A MOUSE

Model a computer mouse similar to the one shown below or use your imagination to model a different mouse. As a hint, create some boundary curves on different planes and use them to form freeform surfaces. Use these quilt surfaces to create the solid. Add and subtract blocks and pads to attach the accessories like buttons.
CHAPTER 8 – ASSEMBLY MODELING

This chapter introduces assembly modeling. Every day, we see many examples of components that are assembled together into one model such as bicycles, cars, and computers. All of these products were created by designing and manufacturing individual parts and then fitting them together. The designers who create them have to carefully plan each part so that they all fit together perfectly in order to perform a function.

In this chapter you will be learning two kinds of approaches used in assembly modeling. We will practice assembly modeling using an impeller as an example. Some parts of these assemblies have already been modeled in earlier chapters.

8.1 OVERVIEW

Unigraphics assembly is a part file that contains the individual parts. They are added to the part file in such a way that the parts are virtual in the assembly and linked to the original part. This eliminates the need for creating separate memory space for the individual parts in the computer. All the parts are selectable and can be used in the design process for information and mating to insure a perfect fit as intended by the designers. The following figure is a schematic which shows how components are added to make an assembly.

8.2 TERMINOLOGIES

Assembly
An assembly is a collection of pointers to piece parts and/or subassemblies. An assembly is a part file which contains component objects.

Component Objects
A component object is the entity that contains and links the pointer from the assembly back to the master component part.

Component Parts
A component part is a part file pointed to by a component object within an assembly. The actual geometry is stored in the component part and is referenced, not copied, by the assembly.
8.3 ASSEMBLY MODELS

There are two basic ways of creating any assembly model.

- Top-Down Modeling
- Bottom-Up Modeling

8.3.1 Top-Down Modeling

The assembly part file is created first and components are created in that file. Then individual parts are modeled. This type of modeling is useful in a new design.

- Create component objects first.
- Make a component the Work Part.
- Create geometry in the component part.
8.3.2 Bottom-Up Modeling

The component parts are created first in the traditional way and then added to the assembly part file. This technique is particularly useful when parts already exist from the previous designs and are being reused.

8.3.3 Mixing and Matching

You can combine these two approaches, when necessary, to add flexibility to your assembly design needs.

8.4 MATING CONDITIONS

When component objects are added to the assembly part file, each component object is mated with the corresponding objects. By putting mating conditions on components of an assembly, you establish positional relationships, or constraints, among those components. These relationships are termed mating constraints. A mating condition is made up of one or more mating constraints. There are 8 mating constraints as shown below.

- **Mate** – Planar objects selected to mate will become coplanar and the direction of the normals will be opposite to each other.

- **Align** – Planar objects selected to align will be coplanar but the normals to the planes will point in the same direction. Centerlines of cylindrical objects will be in line with each other.
- **Angle** – This fixes a constant angle between the two object entities chosen on the components to be assembled.

- **Parallel** – Objects selected will be parallel to each other.

- **Perpendicular** – Objects selected will be perpendicular to each other.

- **Center** – Objects will be centered between other objects, i.e. locating a cylinder along a slot and centering the cylinder in the slot.

- **Distance** – This establishes a +/- distance (offset) value between two objects

- **Tangent** – This establishes a tangent relationship between two objects, one of which has to be curved such as a free form surface, a circle, a sphere, or a cylinder.

The Mating Conditions dialog box is shown below.
8.5 IMPPELLER ASSEMBLY

We will assemble the impeller component objects. All the part files will be provided to you.

- Create a new file and save it as Impeller_assembly.prt.
- Choose APPLICATION → MODELING
- Click on APPLICATION again and make sure there is a check mark next to ASSEMBLIES. If not, click on it.

A new toolbar will appear on the screen as shown below.

- Click on ASSEMBLIES from the menu bar

We will be mostly using the COMPONENTS option which includes:

- **ADD EXISTING** – add new component objects whose part files are already present
- **REPOSITION COMPONENT** – reposition component objects
- **MATE COMPONENT** – mate or align the component objects

- Choose ASSEMBLIES → COMPONENTS → ADD EXISTING
The following dialogue box will pop up.

![Select Part Dialog Box]

- Click on **CHOOSE PART FILE**
- Click on the file **Impeller_upper-casing.prt** and click **OK**

The following dialog box will pop up along with a preview window of the component.

![Add Existing Part Dialog Box]

- Choose **OK**

The next dialog box is the Point Constructor.
- Set the point at the origin and click **OK**
- Click **CANCEL** on the next window that pops up
The upper casing will be seen as follows.

Now we will add the second component, the lower casing.

- Click on **ASSEMBLIES → COMPONENTS → ADD EXISTING**

- Click **CHOOSE PART FILE**

- Select the file **Impeller_lower-casing.prt** and click **OK**

The preview window and dialog box will pop up as shown below. Note the Positioning is selected as **MATE** by default.

Now let us mate the upper and the lower casing.

- Choose **OK**
The following dialog box will appear.

Here you can see the different Mating Types which were explained above in section 8.4.

Now let’s give the Mate constraint.

- Make sure the Mate icon is selected in the window.

- First select the face that the arrow is pointing to in the Component Preview window as shown below in the figure on the left.

- Then click on the face of the Upper Casing in the main screen as shown in the figure on the right. You may have to rotate the figure in order to select the face.
Now let’s give the second constraint.

- Click on the Center icon in the Mating Conditions window.
- First select the face on the lower casing in the Component Preview window as shown in the left figure.
- Then select the face on the upper casing in the main screen as shown in the right figure.

We will give one more constraint to fix the degrees of freedom for the lower casing.

- Click on the Align icon in the Mating Conditions window.
➢ Select the two surfaces, first on the lower casing and then on the upper casing, as shown in the figure below.

➢ Click APPLY and then OK.

The two assembled components will be seen as shown in the figure below.

The lower casing is constrained with respect to the upper casing. Now let’s add the impeller.

➢ Choose ASSEMBLIES → COMPONENTS → ADD EXISTING

➢ Click on CHOOSE PART FILE

➢ Open the file Impeller_impeller.prt
➢ Click **OK** on the dialog box

We will apply the Distance constraint.

➢ Click on the Distance icon in the Mating Conditions window

➢ Select the two faces, first on the impeller and then on the casing, as shown in the figure below.

➢ In the Offset Expression box on the Mating Conditions window, enter a value of -3.

➢ On the Mating Conditions window, click **PREVIEW**.
The preview will show the impeller oriented in the direction opposite to the one we want.

- On the Mating Conditions window, right-click on the Distance constraint we gave
- Choose **ALTERNATE SOLUTION**
- Or
- Click on this Icon near the Selection Steps in the Dialog Box.

Now the impeller will be oriented in the right direction.

Now we will apply the Center constraint to the model.

- Click on the Center icon.
- Select the two surfaces, first on the impeller and then on the casing, as shown in the figure.
Click APPLY and then OK

Save the assembly file.

We will now add the shaft.

- Click on ASSEMBLIES → COMPONENTS → ADD EXISTING
- Click on CHOOSE PART FILE
- Open the file Impeller_shaft.prt.
- Click OK on the dialog box
- Choose the Center icon.
- Select the two surfaces, first on the shaft in the preview window and then on the impeller on the main screen as shown in the figures below.

- Choose the Mate constraint.
First select the face on the shaft and then select the bottom face of the hole in the impeller as shown.

Choose APPLY and then click OK

The assembly will now look like the figure below.

Click on ASSEMBLIES → COMPONENTS → ADD EXISTING

Click on CHOOSE PART FILE and open the file Impeller_hexa-bolt.prt.

Click OK on the dialog box.

Choose the Center constraint.
First select the outer cylindrical threading on the bolt and then select the inner surface of the hole on the upper casing as shown in the figures below.

Now choose the **Mate** constraint.

Select the flat face on the bolt and the face on the rib of the upper casing as shown.

Click **APPLY** and then **OK**.
The assembly is shown below.

- Repeat the same procedure as before to add the part file `Impeller_washer.prt`
- Choose the *Center* constraint
- Select the inner face of the washer and the cylindrical threading on the bolt as shown.

- Choose the *Mate* constraint
- Select the flat face of the washer and then the face on the rib of the lower casing as shown
- Click **APPLY** and then **OK**
The Assembly is shown below.

- Add the part file **Impeller_hexa-nut.prt**
- Choose the **Center** constraint
- First select the inner cylindrical face of the nut and then the outer cylindrical face of the washer as shown

- Choose the **Mate** constraint
- First select the flat face on the nut and then on the face on the washer as shown.
- Click **APPLY** and then **OK**
The assembly now will look as shown in the figures below.

- Repeat the same procedure to add bolts, washers, and nuts to all the holes in the casing. This completes the assembly of the impeller.

There is a simpler way to assemble the bolt, washer, and nut set. Instead of adding the three parts individually, you can assemble these components separately in another file. This will be a sub-assembly. You can insert this subassembly and mate it with the main assembly.
The Final Assembly will look as the shown below. Save the Model.

8.6 EXPLODED VIEW OF IMPELLER ASSEMBLY

In this section we are going to create an Exploded view of the Assembly to show a good picture of the parts involved in the product. In today’s industrial practice, this kind of views are very helpful in the Assembly Shop-floor to get a good idea of which item fixes where. The user should understand that exploding an assembly does not mean relocation of the components, but only viewing the models in a form of disassembled and arranged. You can ‘Unexplode’ the view at any time you want to regain the original assembly view. Let us explode the Impeller Assembly.

➢ Choose ASSEMBLIES → EXPLODED VIEWS → CREATE EXPLOSION

This will pop a Dialog box asking for the name of the Explosion view to be created. You can leave name as the default name and choose OK

Now the UG environment is in Exploding view environment though you don’t find any difference. When we start exploding some assembly, we should decide upon a component to
keep it as the reference position. This component should not be moved from its original position. For this case the impeller is the right option.

- Right Click on the Upper casing and choose **EDIT EXPLOSION**.

This will pop up a Dialog window for Edit Explosion and a Coordinate system on the component.

- Click on the **Z** axis; hold the Button and Drag upwards until the reading in the Distance shows **20** as shown in the following figure.

![Edit Explosion dialog window](image)

- Choose **OK**

- Right click on the Lower casing and choose **EDIT EXPLOSION**.

Again this will pop up a Dialog window for Edit Explosion and a Coordinate system on the component.

- Click on the **Z** axis; hold the Button and Drag downwards until the reading in the Distance shows **-20** as shown in the following figure. Choose **OK**
Right click on the Shaft and choose **EDIT EXPLOSION**.

This time click on the Y axis; hold the Button and Drag right side until the reading in the Distance shows **-25** as shown in the following figure. Choose **OK**.
Select all the Six Hexagonal bolts in the assembly by clicking on them.

Right click on one of them and choose **EDIT EXPLOSION**.

This time click on the **Z** axis; hold the Button and Drag upwards until the reading in the Distance shows **25** as shown in the following figure. This will move all the six Bolts together to the same distance. Choose **OK**.

Like wise select all the six hexagonal nuts together and move them downwards to a value of -30 and the six washers to the distance of -27. This is the Exploded view of the assembly. The following are the pictures of the Final Exploded view. You can rotate and see how it looks like.
It you want to unexploded any particular component,

- Right click on the Component and choose UNEXPLODE.

If you want to unexplode all the components,

- Choose ASSEMBLIES → EXPLODED VIEWS → UNEXPLODE COMPONENT

Select all the components and Choose OK or Tick mark.
8.7 EXERCISE - ARBOR PRESS ASSEMBLY

In this tutorial, we have modeled various parts, some of which are components of the arbor press which is shown below. Assemble the arbor press using the components that you have modeled in addition to ones that are provided to you that you have not modeled before. The complete list of parts that the arbor press assembly consists of includes:

- Allen Bolt
- Allen Nut
- Base
- Circle base
- End clip
- Handle
- Hexagonal Bolt
- L-bar
- Pin
- Pinion
- Pinion handle
- Plate
- Rack
- Sleeve

All these parts are provided in a folder that can be accessed along with this tutorial in the same internet address.
CHAPTER 9- MANUFACTURING

As we discussed in Chapter 1 about the product realization process, the models and drawings created by the designer have to undergo further processes to get to the finished product. This being the essence of CAD/CAM integration, the most widely and commonly used technique is to generate program codes for CNC machines to mill the part. This technological development lessens the amount of human intervention in creating CNC codes. This also facilitates the designers to create complex systems. In this chapter we will cover the Manufacturing Module of Unigraphics-NX3 to generate CNC codes for 3-Axis Vertical Machining Centers.

9.1 GETTING STARTED WITH MANUFACTURING MODULE

There are a few preparations to be done on every CAD model before moving it into the CAM environment. Throughout this chapter, we are going to work with one of the models that were given in the exercise problems. For a change all the units are followed in millimeters in this model and manufacturing of the component.

9.1.1 Creation of Blank

After completing the modeling, you should decide upon the raw material shape and size that needs to be loaded on the machine for the actual machining. This data has to be input to Unigraphics. This can be done in two ways. The first method is by creating or importing the model of the raw material as a separate solid in the same file and assigning that solid as the Blank. The second method is by letting the software decide the extreme dimensions of the designed part and some offset values if wanted. The latter method allows you to more quickly assign the raw size details but can only be used for prismatic shapes.

- Open the file ‘Die_cavity.prt’ of the exercise problem in Chapter 6.
- Click on APPLICATION → MODELING
- Create a block with the following dimensions and positioning.
  - Length = 150 inches
  - Width = 100 inches
  - Height = 80 inches
  - Position the block at the point (-75, -50, -80).
Remember that the Point Constructor icon is located on the toolbar.

This block encloses the entire design part as shown so we will change the display properties of the block. Two features, labeled as **SOLID BODY**, show up in the Part Navigator, one for the design part and one for the block.

- Click on the labels to see which one represents the block
- Right-click on the label for the block
- Choose the option **EDIT DISPLAY**
- When the window pops up, change the display color and change the translucency to 50. Then click **OK**

![Edit Object Display](image)

Once this is done, we will assign the block as Blank in order to better discriminate between the block and the design part.

- Choose **EDIT → BLANK → BLANK**

- Select the Rectangular block that is created now and click **OK**

This will make the raw block disappear from the environment. Whenever you want to view or work on this solid, reverse the blanks. This is done by pressing `<Ctrl>` + `<Shift>` + `<B>`. After making the changes, make sure to return to the original design part by reversing the blanks once again.

### 9.1.2 Setting Machining Environment

Now we are set to get into the Manufacturing module.

- Select **APPLICATIONS → MANUFACTURING**
A window will pop up asking for the Machining Environment Setup. There are many different customized CAM sessions available for different machining operations. Here, we are only interested in the Milling operation.

- For CAM Session Configuration, select `cam_general` and for CAM Setup, select `mill_contour`.
- Click **INITIALIZE**

### 9.1.3 Operation Navigator

As soon as you get into the Manufacturing environment, you will notice many changes in the main screen such as new icons that are displayed.

- Click on the Operation Navigator tab on the right

The Operation Navigator gives information about the programs created and corresponding information about the cutters, methods, and strategies.

The list of programs can be viewed in different categorical lists. There are four ways of viewing the list of programs in the Operation Navigator. The four views are Program Order view, Machine Tool view, Geometry view and Machining Method view. If you want to view the list of programs under different cutter tools, you can do so by clicking the particular icon in the top toolbar.
9.1.4 Machine Coordinate System (MCS)

- Click on the **Geometry View** icon in the toolbar to initiate setup for programming.

- On the Operation Navigator window, double-click on **MCS_MILL**.

A pop-up window will allow you to set the MCS however you want. Unigraphics by default takes the original WCS as the MCS.

- Click **OK** when you are done orienting and positioning the MCS.

9.1.5 Geometry Definition

- **Double-click** on **WORKPIECE** in the Operation Navigator. If you don’t see it, click on the plus sign next to **MCS_MILL**.

The pop up window **MILL_GEOM** appears. This is where you can assign the part geometry, blank geometry, and check geometry if any.

- Click on the Part icon and then click **SELECT**.
Select the design part and click OK.

Now we have to select the Blank Geometry.

Click the Blank icon and click SELECT.

This will open the Blank Geometry Window. As mentioned earlier there are many ways to assign the blank. You can use a solid geometry as the Blank or can allow the software to assign a prismatic block with desired offsets in the X, Y, and Z directions. As we have already created a Rectangular Solid Geometry, we can use that as the Blank geometry. Remember that our block is hidden.

Retrieve the block by pressing <Ctrl> + <Shift> + B.

In the Blank Geometry window, make sure the Geometry radio button is selected.
Select the block and click OK

Bring the part geometry back by pressing <Ctrl> + <Shift> + B once again.

Click OK on the MILL_GEOM dialog box.

Now we are finished assigning the Part and Blank geometries. Sometimes it may be required to assign Check geometry. This option is more useful for more complex shapes or 5 Axes Milling operations where the Tool cutters have a higher chance of dashing with the fixtures. In our case, it is not very important to assign a Check Geometry.

9.2 CREATING OPERATION AND PARAMETER SETTING

9.2.1 Creating a new Operation

The Manufacturing setup is now ready for us to work further with Programming Strategies. There are many different strategies involved in programming and it takes practice to know which one is the most efficient. Here, the basic guidelines are given for the most widely and frequently used strategies. The chapter will also cover important parameters that are to be set for the programs to properly function.
Click on the Create Operation icon in the toolbar as shown.

The Create Operation window will pop up.

Leave the Type of operation to be `mill_contour`.

There are many different subtypes under Mill-Contour, namely Cavity Mill, Z-Level Follow Cavity, Follow Core, Fixed Contour, and so on. These different subtypes are used for different situations and profiles of the design part. As mentioned before, how you select a strategy for any situation depends on your experience.

Click on the `CAVITY_MILL` icon at the top left as shown in the figure.

Change the Program from NC_PROGRAM to PROGRAM.

Change the Use Geometry to WORKPIECE.

Name the program PROG1. Then click OK.

The program parameters window with CAVITY_MILL in the title bar will pop up. On this window, you can set all the parameters for the program. A brief introduction on every important parameter and terminology will be given as we go through the sequence.

### 9.2.3 Tool Creation and Selection

One of the most important decisions to make is selecting the right shape and size of the tool to use. Before starting with the Tool parameter settings, we must first know about the types of Tool cutters. The Milling tool cutters are basically categorized into three main forms of cutters. When selecting a cutter, it is important to take into consideration the size, shape, and profiles of the design parts. For example, if the corner radius of a pocket is 5 mm, the pocket should be finished by a cutter with diameter less than or equal to 10 mm. Otherwise it will leave material at the corners. There are other special forms of cutters available in markets that are manufactured to suit this need.
**Flat End Mill Cutters:**
These cutters have a sharp tip at the end of the cutter as shown in the figure. These cutters are used for finishing parts that have flat vertical walls with sharp edges at the intersection of the floors and walls.

![Flat End Mill Cutter Image]

**Ball End Mill:**
These cutters have the corner radii exactly equal to half the diameter of the shank. This forms the ball shaped profile at the end. These cutters are used for roughing and finishing operations of parts or surfaces with freeform features.

![Ball End Mill Cutter Image]

**Bull Nose Cutters:**
These cutters have small corner radii and are widely used for roughing and semi-finishing most of the parts and also for finishing of inclined and tapered walls.

![Bull Nose Cutter Image]

- On top of the parameters window, click on the **GROUPS** tab.
- Click on the Tool radio button
- Click **SELECT**

![Parameter Window Image]
The cutter that we are going to use to rough out this huge volume is BUEM12X1 (Bullnose End Mill with 12 diameter and 1 corner radius).

- Click NEW

- On the New Tool window, select the Mill icon

- Type in BUEM12X1 as the Name and click OK

This will open another window to enter the cutter dimensions and parameters. You can also customize the list of tools that you would normally use and call the cutters from the library.

- Enter the values as shown in the figure below.

- Click OK.

- Back on the parameters window, click on the MAIN tab.
9.2.4 Cut Method

There are many different cut method options available. The following is a description of each.

- **Zig-Zag**: This tool takes a zigzag path at every level of depth. It saves time by reducing amount of air cutting time (idle running). The climb and conventional cuts alternate.

- **Zig**: This takes a linear path in only one direction of flow.

- **Zig with Contour**: This takes the path in one direction either climb or conventional. The unique thing is that it moves along the contour shape nonlinearly.

- **Follow Periphery**: This takes the path depending upon the periphery profile. For example the outer periphery of our part is rectangular. So the tool path will generated such that it gradually cuts the material from outside to inside with the stepover value. This option is mostly used for projections and cores rather than cavities.

- **Follow Part**: This is the most optimal strategy where the tool path is manipulated depending on the part geometry. If there are cores and cavities in the part, the computer intelligently considers them to remove the materials in a optimal way. This is widely used for roughing operations.
Trochoidal: This cutter is huge and is used for removing a large amount of material. The bulk of material is removed by gradual trochoidal movements. The depth of cut used will be very high for this strategy.

Profile: This takes the cut only along the profile of the part geometry. It is used for semi-finishing or finishing operations.

➢ For this exercise, select the Follow Part icon from the Cut Method drop-down menu since we have both projections and cavities in our part.

9.2.4 Step Over and Scallop Height:

Step Over:

This is the distance between the consecutive passes of milling. It can be given as a fixed value or the value in terms of cutter diameter. The stepover should not be greater than the effective diameter of the cutter. Otherwise it will leave extra material at every level of cut and result in an incomplete milling operation. The numeric value or values required to define the stepover will vary depending on the stepover option selected. These options include Constant, Scallop, Tool Diameter, etc. For example Constant requires you to enter a distance value in the subsequent line.

Scallop Height:

Scallop Height controls the distance between parallel passes according to the maximum height of material (scallops) you specify to be left between passes. This is affected by the cutter definition and the curvature of the surface. Scallop allows the system to determine the stepover distance based on the scallop height you enter.
For the Stepover, select **TOOL DIAMETER** and change the Percent to 70.

![Image of CAVITY_MILL dialog box with Stepover and Percent set to 70]

### 9.2.5 Depth per cut

This is the value to be given between levels to slice the geometry into layers and the tool path cuts as per the geometry at every layer. The cut depth value can vary for each level. Levels are horizontal planes parallel to the XY plane. If we don’t give cut levels, the software will unnecessarily try to calculate slices for the entire part and machine areas that are not in our interest.

- Change the Depth per Cut value to be 0.5.

Now we will add the level ranges. This will split the part into different levels along the Z-direction to be machined.

- Click on **CUT LEVELS** as shown below.

![Image of CAVITY_MILL dialog box with Cut Levels highlighted]

This will pop up a Dialog box for Cut levels. On this there are up and down Arrow buttons that can be used to view the range of the different levels. We are not going to mill upto the bottommost face of the Part, but upto the floor at 40mm from top. Therefore, we must delete the last level.
➢ Use the up and down scroll buttons until you reach the level that has a range depth of 80.

➢ Click on the Delete icon to delete this level.

➢ Select OK after making these adjustments.

9.2.6 Cutting Parameters

➢ On the parameters window, click CUTTING
Under the ‘Strategy’ tab button, change the Cut Order from Level First to **DEPTH FIRST**.

Changing the cut order to Depth First orders the software to generate the tool path such that it will mill one island completely up to the bottom-most depth before jumping to another level. This Depth First strategy reduces the non-cutting time of the program due to unnecessary retracts and engages at every depth of cut.

Click on the ‘Stock’ tab button.

Change the value of the Part Side Stock to 0.5.

This value is the allowance given to every side of the part. If you want to give different values to the floors (or the flat horizontal faces), uncheck the box next to ‘Use Floor Same As Side’ and enter a different value for Part Floor Stock.

Choose **OK** after entering the values.
9.2.7 Avoidance

- In the parameters window, click AVOIDANCE

This window consists of many avoidance points like, Start Point, Go home point, Clearance plane etc. Of these, we are concerned with three points. They are as follows.

**From Point:**

This is the point at which the tool change command will be carried out. The value is normally 50 or 100 mm above the Z=0 level to enhance the safety of the job when the cutter is changed by the Automatic Tool Changer (ATC).

- Click FROM POINT
- Choose SPECIFY

- In the Point Constructor, enter the coordinates of XC, YC and ZC as (0, 0, 50).
- Choose OK
- Choose OK again to go back to the Avoidance window.

**Start Point:**

This is the point at which the program starts and ends. This value is also 50 or 100 mm above the Z=0 level to enhance safety. It is also the point at which the machine operator checks the height of the tool mounted on the spindle with respect to the Z=0 level from the job. This cross checks the tool offset entered in the machine.
This time click on START POINT

Choose SPECIFY

Enter the coordinates (0, 0, 50) in the Point Constructor.

Click OK twice

**Clearance Plane:**

This is the plane at which the tool cutter will retract before moving to the next region or island. This can also be known as retract plane. Sometimes the clearance plane is considered to be the previous cutting plane. However, when the tool has to move from one region to another, it is necessary to move to the clearance plane before doing so. The value of the clearance plane should be at least 2 mm above the top most point of the raw piece or fixture or whichever is fixed to the machine bed.

Choose CLEARANCE PLANE

Click SPECIFY

Enter the Offset value as 3

Click on the XY Plane icon toward the bottom of the window.

Click OK three times to go back to the parameters window.

---

9.2.8 Feedrates

Choose FEED RATES to enter the feed and speed parameters.
**Speed:**

Speed normally specifies the rpm of the spindle (spindle speed). However, technically the speed refers to the cutting speed of the tool (surface speed). It is the linear velocity of the cutting tip of the cutter. The relative parameters affecting this linear speed are rpm of the spindle and the diameter of the cutter (effective diameter).

- Check the box next to **Spindle Speed**
- Enter the Spindle Speed value as 4500.

For the Surface Speed and the Feed per Tooth, you should enter the recommended values given by the manufacturers of the cutter. By entering these values, the software will automatically calculate the cutting feed rate and spindle speed. You can also enter your own values for feed rates and spindle speeds.

**Feeds:**

There are so many feeds that are involved in a single program. The most important is the Cutting feed. This is the feed at which the tool will be in engagement with the raw piece and actually cutting the material off the work piece. It is the relative linear velocity at which the cutter moves with respect to the job.

The other feeds are also required, but not always. Some machine control systems use their default retracts and traverse feed. In those cases, even if you do not enter the values of other feeds, there won’t be any problems. Some control systems may look for these feed rates from the program. It can be slightly less than the machine’s maximum feed rate.

- Click the **FEEDS** tab
- For this exercise, enter the values as shown in the figure. Make sure to enter the Cut value as 1200 mmpm.
- Click **OK**
9.3 PROGRAM GENERATION AND VERIFICATION

9.3.1 Generating Program

Now we are done entering all the parameters required for the roughing program. It is time to generate the program.

➢ Click on the Generate icon at the bottom of the window.

You can now observe the software slicing the model into depths of cuts and creating toolpaths at every level. You can find on the model cyan, blue, red and yellow lines as shown in the figure.

During the generation, you will be prompted with a Display Parameters window.

➢ Uncheck the box next to Pause After Display

➢ Then click OK to see the display of cut-levels and tool paths.

➢ After the generation is done, click OK in the parameters window.
9.3.2 Tool Path Display

Whenever you want to view the entire toolpath of the program, right-click on the program in Operation Navigator and click Replay. It will give the display as shown in the Figure.

You can now observe that next to PROG1 in the Operation Navigator is a yellow exclamation point instead of a red mark. This means that program has been generated successfully but has yet to be post-processed. If any change is made in the model, the program will again have a red mark next to it. This implies that the program has to be generated again. However, there is no need to change any parameters in the program.

9.3.3 Tool Path Simulation

It is very important to check the programs you’ve created. This prevents any improper and dangerous motions from being made in the cutting path. It is always possible that you may give wrong parameters and settings that cause costly damages in the work piece. To avoid such mistakes, Unigraphics and other CAM software provide Toolpath verification and a Gouge check.
Verify:

The Tool Path verification can be used to view the cutter motion in the entire program. You can observe how the tool is getting engaged and how it retracts after cutting. It also shows the actual material being removed through graphical simulation. You can also view the specific zone of interest by moving the line of the program.

- Right-click on the program in the Operation Navigator.
- Choose TOOL PATH → VERIFY

- On the Tool Path Visualization window, click on the Play icon to view the Tool Path motion.

You can also view the visualization in different modes by changing the options in the drop-down menu next to Display.
- Click on the **3D DYNAMIC** tab on the same window.

- Click on the **DISPLAY OPTIONS** button on the same window to pop a Dialog box as shown in the figure.

- Change the **Number of Motions** to 50.

- Change the **Animation Accuracy** to **FINE**.

- Change the **IPW Color** to Green.

- Click on the **Play button** again.

The simulation will look as shown in the figure below.
With this option, you will be able to view the actual cutting simulation and material removal through computer graphics. This is 3D Dynamic, where you can rotate, pan and Zoom the simulation when it is playing. The cutting simulation is 3D. This option was not available in the previous versions.

Let us try the 2D Dynamic simulation. When this simulation is playing, you cannot do any other actions in Unigraphics. Unlike 3D, you cannot rotate or zoom while playing. If you want to see the other side of the part, you have to stop the simulation, rotate and play again. This is faster than 3D Dynamic, for obvious reason.

- Click on the **2D DYNAMIC** tab on the same window
- Click on the **Play button**
- Click **OK** when you are done.

The simulation will look as shown in the following picture.
9.3.4 Gouge Check

Gouge Check is used to verify whether the tool is removing any excess material from the raw material with respect to Part Geometry. Considering a Design Tolerance, any manufacturing process may produce defective parts by two ways. One is removing excess material which is also called Less Material Condition. The other one is leaving materials that are supposed to be removed which is More Material Condition. In most cases, the former is more dangerous since it is impossible to rework the design part. The latter is safer since the leftover material can be removed by reworking the part. The gouge check option checks for the former case where the excess removal of material will be identified.

➢ Right-click the program in the Operation Navigator.

➢ Choose TOOL PATH → GOUGE CHECK

After the gouge check is completed, a message box will pop up saying “No gouged motions were found.” If in case there are any gouges found, it is necessary to correct the program.

➢ Click OK on the message box

9.4 OPERATION METHODS

9.4.1 Roughing

Any milling operation should be rough milled before finishing the job. This practice is very strictly followed in industry. The main purpose of roughing is to remove bulk material at a faster rate, without affecting the accuracy and finish of the job. Stock allowances are given to provide enough material for the finishing operation to get an accurate and good finish job. What we did in the previous chapter is generate a roughing program. Now we have to moderately remove all the uneven material left over from the previous program.
9.4.2 Semi-Finishing

Semi-Finishing programs are basically intended to remove the uneven material and keep even part stock allowance for the Finishing operations. Once we are done with the first roughing program, semi-finishing is always easier and simpler to perform.

Now we will copy and paste the first program in the Operation Navigator. In the new program, you only have to change a few parameters and cutting tool dimensions and just regenerate the program.

- Right-click PROG1 in the Operation Navigator and click COPY
- Right-click PROG1 again and choose PASTE.
- Right-click the second PROG1 you just made and click RENAME. Rename the second program PROG2.

You can see that next to the newly created PROG2 is a red mark, which indicates that the program is not generated.

**Cutter Selection:**

Let us now set the parameters that need to be changed for the second program. Before we even start, we should analyze the part Geometry to figure out the minimum corner radius for the cutter diameter. In our model it is 5 mm and at the floor edges it is 1 mm. Therefore, the cutter diameter can be anything less than 10 mm. For optimal output and rigidity, we will choose a Bull Nose Cutter with a diameter of 10 and a lower radius of 1.
- **Double-click PROG2** on Operation Navigator to open the parameters window.

Just like we did in the previous program we have to create a new cutter.

- Click on the ‘**GROUPS**’ Tab.

It will show BUEM12X1 as the current tool.

- Choose **RESELECT**

- Create a new cutter and name it **BUEM10X1**. It should have a diameter of 10 and a lower radius of 1.

- After creating the tool, click on the **MAIN** tab

- Click the Global Depth per Cut as 0.25

- Then click on **CUTTING**

- Click on the **STOCK** tab button.

- Uncheck the box next to **Use Floor Same As Side**

- Enter 0.25 for Part Side Stock

- Enter 0.1 for Part Floor Stock

- Click on the **CONTAINMENT** tab button.
In the drop-down menu next to In Process Workpiece, choose **USE 3D**

In Process Workpiece is a very useful option in Unigraphics. The software considers the previous program and generates the current program such that there is no unnecessary cutting motion in the No-material zone. This strategy reduces the cutting time and air cutting motion drastically. The algorithm will make the cutter only remove the material left in the precious program and maintain the current part stock allowance.

- Choose **OK** to return back to the parameters window.
- Click **FEED RATES**
- Enter the Speed and Feed values as shown in the following figures.
- Then click **OK**

The parameters and settings are finished for the semi-finishing program.
Regenerate the program by clicking on the Generate icon. After the software finished generating, click OK. Then replay the Tool Path visualization. The overall Tool Path generated in the second program will look like the following figure.

![Tool Path Visualization](image)

### 9.4.3 Finishing Profile

So far we are done with the roughing and semi-finishing programs for the part. There is a sufficient amount of material left in the Workpiece to be removed in the finishing programs to obtain the accurate part geometry as intended in the design. The finishing programs should be generated such that every surface in the part should be properly machined. Therefore, it is better to create more than one program to uniquely machine sets of surfaces with relevant cutting parameters and strategies rather than make one program for all the surfaces. The following illustrates how to group the profiles and surfaces and create the finishing programs.

**Outer Profile:**

This program is intended to finish the outer inclined walls onto the bottom of the floor. Because the program should not touch the contour surface on the top, we have to give Check and Trim boundaries in the program.

- Repeat the same procedure as before to copy and paste PROG2 on Operation Navigator.
- Rename the program PROG3.
- Double click PROG3 to make parameter changes.
In the popped up parameters window, change the Cut Method to Profile and the Stepover percentage to 40 as shown in the figure.

Click on the MORE tab

Click SELECT

The Boundary Geometry window will pop up. Make sure to carry out the following procedure in the right sequence.

Change the ‘Side Trimmed’ to INSIDE

Change the ‘Geometry Type’ to TRIM

This tells the software that the cutter should not cut material anywhere inside the boundary. Trim allows you to specify boundaries that will further constrain the cut regions at each cut level.

Change Mode to CURVES/EDGES
A new window will pop up as shown below.

- Change the Plane to be **USER-DEFINED**

Another window will pop up asking for the mode of selection of the plane on which the curves should be projected. This should normally be over the topmost point of the part geometry. Precisely, it should be over the MCS.

- Click on the **ZC** Constant icon under **Principal Planes**
- Enter a value of 3.0 next to it.
- Click **OK**

Now we will start selecting edges from the part. These selected edges will be projected on the Z=3 plane as curves and used as the boundary.

- Select all the top outer edges on the wall along the contour surface as shown in the figure. Make sure to select all 8 edges and in a continuous order.
- Choose **OK**
Now we have to redo the same process with one small change. Instead of Trim in the Geometry type we have to select Check. When the tool encounters Check Geometry, it will cut around it.

- For Geometry Type, select **CHECK**
- For Material Side, select **INSIDE**
- Now select the Mode to be **CURVES/EDGES** as shown in the figure.

- Next to Plane, choose **USER-DEFINED**. If it is already selected, choose it again. **Do not click OK.**
- Choose the Principal plane to be ZC and enter a value of 3.0.
- Choose **OK**
- Again, select the top outer edges, exactly as illustrated before.
- Click **OK**
- Choose **OK** again on the Boundary Geometry window to return to the parameters window.
- Click on the **MAIN** tab button on the parameters window.
- Enter the ‘**Global Depth per Cut**’ to be 0.2.
- Click **CUTTING**
- In the pop up Dialog box, click on ‘**STOCK**’ tab button
- Enter the **Part Side Stock** and **Part Floor Stock** values to be 0.00.
**Intol:**
Intol allows you to specify the maximum distance that a cutter can deviate from the intended path into the workpiece.

**Outtol:**
Outtol allows you to specify the maximum distance that a cutter can deviate from the intended path away from the workpiece.

- Enter the Intol and Outtol values to be 0.001 as shown in the figure.

- Click on ‘CONTAINMENT’ tab button

- Change the In Process Workpiece to **NONE**

- Click **OK**

- Click on the Generate icon to generate the program in the Main Parameters window.

You may get a warning message as shown in the figure on the right. Choose **OK**.
➢ Click OK on the parameters window when the program generation is completed.

The finishing program for the outer profile is now ready. You can observe while replaying the tool path that the cutter never crosses the boundary that has been given for trim and check. The cutter retracts to the Z=3 plane for relocation.

Inner profile:

We will repeat the same procedure as for PROG3 but this time we will select the inner loop as the boundary.

➢ Copy and paste PROG3 in the Operation Navigator and rename it as PROG4.

➢ Double-click PROG4 to edit the parameters or Right click on it and Choose Edit

➢ Click the MORE tab

➢ Click RESELECT and Choose OK on the message box.
Select the Material Side to be **OUTSIDE** and the Geometry Type to be **TRIM** on the Pop up dialog box.

This will prevent the cutter from passing outside the boundary.

Select the Mode to be **CURVES/EDGES**.

Again choose the plane to be **USER-DEFINED** in the Create Boundary window.

Choose at ZC plane and enter the offset distance as 3.

Click **OK**
Select all the top inner edges along the contour surface as shown in the figure. Again, make sure all 8 edges are selected in a continuous order.

Then click OK.

Repeat the same procedure but change the Geometry Type to CHECK.

Remember to set the plane at Z=3.

Select the same inner edges to create the Check boundary.

Choose OK twice to return back to the parameters window.
Generate the program. Click OK when the generation is finished. Click on OK if you get any warning message about the tool fitting.

The finishing program for the outer profile is now ready. By replaying the tool path, you can observe that the cutter never crosses the boundary that has been given for trim and check.

9.4.4 Finishing Contour Surface

Now we have to use a different type of strategy to finish the top freeform surface.

- Click on the Create Operation icon in the Toolbar.
- Then click on the FIXED_CONTOUR icon as shown in the figure.
- Choose PROGRAM for Program
- Choose WORKPIECE for Use Geometry
- Enter the Name as PROG5
- Click OK
On the parameters window, under Drive Method, select BOUNDARY even if it is already shown.

On the Boundary Drive Method window, choose SELECT at the top of the window.

On the Boundary Geometry window, change the Mode to CURVES/EDGES.

The Create Boundary window will pop up.

Select the Material Side to be OUTSIDE

Select the Tool Position to be ON.
The tool position determines how the tool will position itself when it approaches the boundary member. Boundary members may be assigned one of three tool positions: On, Tanto, or Contact.

- In an ON position, the center point of the tool aligns with the boundary along the tool axis or projection vector.
- In a Tanto position, the side of the tool aligns with the boundary.
- In a Contact position, the tool contacts the boundary.

➢ For the Plane, choose **USER-DEFINED**

➢ Again, set the plane to be \( Z=3 \)

➢ Click **OK**

➢ Select the outer loop of the top contour surface as shown in the figure. Remember to select the edges in a continuous order.

[Image of 3D model with selected loops and plane]

➢ Click **OK**

We have trimmed the geometry outside the loop. Now we have to trim the geometry inside the inner loop so that the only geometry left will be the area between the two loops.

➢ Choose the Mode to be **CURVES/EDGES**

➢ Choose the Material Side to be **INSIDE** and Tool Position to be **ON**
➢ Choose the plane to be user-defined at \( Z=3 \)

➢ Select the inner edges of the contour surface as shown.

![Diagram showing plane selection](image)

➢ Click **OK twice** to return to the **Boundary Drive Method** window.

➢ Change the Stepover method to **SCALLOP** and enter the height to be **0.001**

➢ Choose **OK** to return back to the main parameters window.

In the Parameters Window,

➢ Click on **CUTTING**

➢ Click on **STOCK** tab button and enter the values as shown

![Parameters window](image)
Click on the **MORE** tab button and enter the value of percent as 1.0.

![Cutting Parameters window](image)

- Click **OK**.
- Then click on **FEED RATES** on the parameters window.
- Enter the Speed parameters as shown in the following figure.
- Click **OK**

In the Main Parameter window,
- Click on the **GROUPS** tab button
- **RESELECT** the Tool and Create a new tool and name it **BEM10**
- Change the diameter to be **10 mm** and the lower radius to be **5 mm**.
- Click **OK**
- **Generate** the program.
The contour surface is now finished and you can view the simulation by Toolpath verification.

9.4.5 Flooring

Flooring is the finishing operation performed on the horizontal flat surfaces (Floors) of the part. In most of the milling processes flooring will be the final operation of the process. All the horizontal surfaces have to be finished. This is a planar operation that runs the cutter in a single pass on every face.

- Click on the Create Operation icon on the Toolbar.
- Change the Type to be `mill_planar` at the top of the window.
- Change all the options as shown in the figure.
- Click OK
In the parameters window, change the **Cut Method** to be **Follow Part**.

Change the percent of the tool diameter for stepover to be **40**.

In flooring operations, it is always better to keep the stepover value to be less than half of the diameter of the cutter in order to achieve more flatness on the planar surfaces.

Unlike previous programs, we have to select a cut area.

- Click on the Cut Area icon at the top of the window, second from the left.
- Click **SELECT**

- Select the highlighted surfaces shown in the figure below.
➢ Click OK

➢ Click on CUTTING in the main parameter window.

➢ Choose the STOCK tab button and enter the Intol and Outtol values as shown in the figure.

![Cut Parameters](image)

➢ Click OK

➢ Click on FEED RATES.

Because this is a Flooring operation, it is better to make the spindle speed high and the feed rates low compared to the previous operations.

➢ Enter the values exactly as shown in the figure.

![Feeds and Speeds](image)

➢ Choose OK
Generate the program. Then replay and verify the cutter path.

The following figure shows the toolpath display for the flooring.

9.5 POST PROCESSING

The primary use of the Manufacturing application is to generate tool paths in order to manufacture parts. Generally, we cannot just send an unmodified tool path file to a machine and start cutting because there are many different types of machines. Each type of machine has unique hardware capabilities, requirements and control systems. For instance, it can have a vertical or a horizontal spindle; it can cut while moving several axes simultaneously, etc. The controller accepts a tool path file and directs tool motion and other machine activity (such as turning the coolant or air on and off).

Naturally, just as each type of machine has unique hardware characteristics; controllers also differ in software characteristics. For instance, most controllers require that the instruction for turning the coolant on be given in a particular code. Some controllers also restrict the number of M codes that are allowed in one line of output. This information is not in the initial Unigraphics NX tool path.

Therefore, the tool path must be modified to suit the unique parameters of each different machine/controller combination. The modification is called postprocessing. The result is a postprocessed tool path.
There are two steps involved in generating the final postprocessed tool path.

1. Create the tool path data file, otherwise called CLSF (Cutter Location Source File).

2. Postprocess the CLSF into Machine CNC code (Post processed file). This is a program that reads the tool path data and reformats it for use with a particular machine and its accompanying controller.

9.5.1 Creating CLSF

After an operation is generated and saved, the resulting tool path is stored as part of the operation within the part file. CLSF (Cutter Location Source File) provides methods to copy these internal paths from the operations in the part file to tool paths within the CLSF, which is a text file. The GOTO values are a "snapshot" of the current tool path. The values exported are referenced from the MCS stored in the operation. The CLS file is the required input for some subsequent programs, such as postprocessors.

➢ Click on one of the programs that you want to postprocess in the Operation Navigator.

➢ Click on the Output CLSF icon as shown in the Toolbar.

You can also click TOOLS → OPERATION NAVIGATOR → OUTPUT → CLSF.

A window will pop up to select the CLSF Format.

➢ Choose CLSF_STANDARD

➢ Enter a location for the file.

➢ Choose OK.
The CLSF file will be created. It will be similar to the figure below. The contents of the file contain the basic algorithm of the cutter motion without any information about machine codes and control systems. This file can be used for postprocessing any machine control. The extension of the file is cls (XXX.cls).

Any program that has been output to CLSF or postprocessed will have a green checkmark next to it in the Operation Navigator.
9.5.2 Postprocessing

- Click on a program in the **Operation Navigator** that you want to postprocess.
- Click on the **UG/Post Postprocess** icon as shown in the figure.

You can also click **TOOLS → OPERATION NAVIGATOR → OUTPUT → NX POSTPROCESSING**.

- Select the **MILL_3_AXIS** machine
- Enter a location for the file
- Select **OK**

You may get a warning message as shown below. This is regarding the units that have been set in the selected postprocessor and the units of the Part file. You need not worry about this, as always all the machines has both the units methods (inches /mm). Click **OK**.
This will create the postprocessed file for the desired machine. You can find the block numbers with G and M codes concerning the Machine controller type. The extension of the file is **ptp** (XXX.ptp).

This final output (XXX.ptp) file can be transferred to the machine through DNC or punched tapes and the actual milling operation can be done. This entire sequence starting from the transfer of the model into the Manufacturing module to the transfer of the files to the machine and cutting the raw piece into the final part is called Computer Aided Manufacturing.
CHAPTER 10- FINITE ELEMENT ANALYSIS

FEA, or finite element analysis, is a technique for predicting the response of structures and materials to environmental factors such as forces, heat and vibration. The process starts with the creation of a geometric model. Then, the model is subdivided (meshed) into small pieces (elements) of simple shapes connected at specific node points. In this manner, the stress-strain relationships are more easily approximated. Finally, the material behavior and the boundary conditions are applied to each element. Software such as Unigraphics computerizes the process and makes it possible to solve complex calculations in a matter of minutes. It can provide the engineer with deep insights regarding the behavior of objects.

Some of the applications of FEA are Structural Analysis, Thermal Analysis, Fluid Flow Dynamics, Electromagnetic Compatibility and Motion Simulation. Of these, FEA is most commonly used in structural and solid mechanics applications for calculating stresses and displacements. These are often critical to the performance of the hardware and can be used to predict failures.

In this chapter we are going to deal with the structural stress and strain analysis of solid geometries.

10.1 INTRODUCTION TO FEA

10.1.1 Element shapes and nodes

The elements can be classified into different types on the basis of the number of dimensions and the number of nodes in the element. The following are some of the types of elements used for discretization.

One-dimensional elements:

- 2-node (Linear)
- 3-node (Quadratic)
- 4-node (Cubic)
Two-dimensional elements:

- Triangular
  - 3-node (Linear)
  - 6-node (Quadratic)
  - 10-node (Cubic)
- Quadrilateral
  - 4-node (Linear)
  - 8-node (Quadratic)
  - 12-node (Cubic)

Three-dimensional elements:

- Tetrahedral (a solid with 4 triangular faces)
Hexahedral (a solid with 6 quadrilateral faces)

Types of nodes:

- Exterior nodes
- Corner nodes
- Side nodes
- Interior nodes

The results of FEA should converge to the exact solution as the size of finite element becomes smaller and smaller.

10.1.2 Structure Module

- Copy and paste the file Impeller_impeller.prt into a new folder to avoid from changes being made to the assembly.
- Open this newly copied file
- Click on APPLICATIONS → STRUCTURES

You will find that all the toolbar options in the structures environment are inactive. Before creating a scenario, we will give a brief introduction of all the commands.

The following figure is the toolbar for Finite Element Modeling and Analysis of Structures.

Solution: Click on this icon will open up the CREATE SOLUTION window where you can select the solver algorithm to be Structures P.E, NX Nastran, MSC Nastran, Ansys or Abaqus. Also, you can choose the type of analysis to be performed. In this tutorial, only Structural Analysis will be covered with Structures P.E.
**Material Properties:** This allows you to change the physical properties of the material that will be used for the model. For example, if we use steel to manufacture the impeller, we can enter the constants such as density, Poisson’s ratio, etc. These material properties can also be saved in the library for future use.

**Loads:** This option allows you to determine the type of forces acting on the solid and the directions and magnitude of the forces.

**Boundary Conditions:** Boundary conditions are surfaces that are fixed to arrest the degrees of freedom. Some surfaces can be rotationally fixed and some can be constrained from translational movement.

**3D Tetrahedral Meshes:** This icon is one of the mesh options that can be used to discretize the model as discussed in beginning of the chapter. Normally, we select tetrahedral shapes of elements for approximation. You can still select the 2-D and 1-D elements depending on the situation and requirements by choosing these options from the drop-down menu.

**Solve:** This is the command to solve all the governing equations by the algorithm that you choose and all the above options. This solves and gives the result of the analysis of the scenario.
10.1.3 Scenario Navigator

The Scenario Navigator provides the capability to activate existing scenarios, create new ones, and use the scenario to build mechanisms by creating and modifying motion objects. To display the Scenario Navigator, click the Scenario Navigator tab in the resource bar as shown in the figure.

It shows the list of the scenarios created for the master model file. In each scenario it displays the list of loads, boundary conditions, types of meshes, results, reports generated and so on.

10.1 SCENARIO CREATION

The Structures module is in a way different than when the first scenario is created. Unigraphics creates a folder of the same name as that of the file and at the same location where the file is located. For every scenario, it creates five different files with the name of the scenario. They are xxx.SIM, xxx.DAT, xxx.txt, xxx.out and xxx.VDM. All the results generated for the scenarios are saved as .vdm files. You can think of a scenario model as a variation of a master design model. Scenarios contain all the geometric features of the master model. They also support body promotions and interpart expressions.

Body promotions are used to provide an independently modifiable copy of the master model geometry and serve as a place to hold scenario-specific features such as mid-surfaces.

The scenario model's geometry is linked to the master model geometry, but a scenario may have additional unique information. For example, the master model may contain all the information about the model's geometry, but the scenario model will contain additional motion data, such as information about links and joints.
Now we will create a scenario. *Note:* When you first open any file in Structures module, it will automatically pop up with Solution creation window to create a scenario.

- Click on the Scenario Navigator icon on the navigator toolbar.
- Right-click on Impeller_impeller and choose **NEW SCENARIO**

![Scenario Navigator](image)

This will pop CREATE SOLUTION dialog box to create a new scenario. Enter the name of the first scenario as ‘Analysis_1’. Change the Solver type into ‘STRUCTURES P.E’ and Analysis type as **STRUCTURAL**.

![Create Solution](image)

- Choose OK to create a new Scenario.

The Scenario Navigator will now look like the following figure.

![Scenario Navigator](image)
10.2.1 Material Properties

The next step is to give the material properties to the solid model for this scenario. Because we don’t have any data in the library to retrieve for standard material, we will create one. Let us assume that we will use steel to manufacture the impeller.

- Click on the Material Properties icon on the tool bar

The Materials window will pop up.

- Enter the name and values as shown in the following figure. Pay attention to the units. (Note that 30e6 represents 30X10^6).

- Choose APPLY and then click OK

![Material Properties Window]

10.2.2 Loads

Now the loads applied on the solid model should be input to the system. For the impeller, the major force acts on the concave surfaces of the turbine blades. Approximately this is considered to be normal pressure on all the five surfaces. Since we are not too concerned about the magnitude of the load, let us take the value to be 100 lbf/sq inch to exaggerate the deformation of the blades.

- Click on the Loads icon

- In the pop dialog box, change the Type to NORMAL PRESSURE

![Loads Window]
➢ Click on the five concave surfaces of the blades as shown in the following figures.

![Image of a blade with arrows indicating concave surfaces](image)

➢ Enter the value for Pn as 100 and keep the units as lbf/in² (psi).

➢ Choose OK

10.2.3 Boundary Conditions

Let us give the boundary conditions for the scenario. Actually the impeller rotates about the axis of the cone with the shaft as you can see in the assembly in the previous chapters. It is not fixed. But our concern is the deformation of the blades with respect to the core of the impeller. The conical core is relatively fixed and the deformations of the blades are to be analyzed accordingly.
Click on the Boundary Conditions icon

Click on the conical surface of the impeller as shown in the following figure. The default option is for both translational and rotational motions to be fixed. Keep these default options.

Choose OK

10.2.4 Meshing

The Meshing has to be defined at this stage by defining the type and size of the element.

Click on the **3D Tetrahedral Mesh** icon
A window will pop up asking for the type and size of the elements.

- Click on the solid object model on the graphic screen
- There are two types of tetrahedral elements available in Unigraphics. One is with 4 nodes and another is with 10 nodes.
- Choose the Type to be TETRA10
- Enter the Overall Element Size as 1.0
- Choose OK

You can find the Solid model with small tetrahedral elements. It will look like the figure shown below.
Right Click on the 3d Mesh(1) and Choose ASSIGN MATERIAL.

On the Material Properties window, click on the STEEL and Choose OK.

10.3 SOLVING AND RESULT SIMULATION

10.3.1 Solving the Scenario

The Finite Element Model is now ready for solving and analysis.

Click on the Solve icon.

This will open the Solve window. You can expand the window by clicking on the green arrow as shown. After doing so, you will be able to save the files to a specific location.

Click OK without making any changes.

It may take awhile to generate the results. Wait until the Analysis Job Monitor window appears, showing the job to be complete.

Click on CANCEL.
10.3.2 FEA Result

- Open the Scenario Navigator
- **Double-click on RESULTS** to see the analysis results
- Click on the Display Marker Toggle Icon on the Post Control Toolbar.

The screen will now appear as shown below.

You can easily interpret the results from the color coding. The orange-red color shows the maximum deformation zones and the blue area shows the minimum deformation zones. You can see that because the conical core is fixed, it experiences zero deformation. The analysis also shows that the maximum deformation experienced at the tip of the blades is $1.935 \times 10^{-3}$. 
On the Scenario navigator, you can keep changing the results by clicking on each option as shown below. The one with Red tick mark is currently active. You can click on the other inactive marks to see various results.

Some of the other results are shown below.
10.3.2 Simulation

- Click on the Animation icon on the Post Control Toolbar.
- In the Animation Setup window, change the number of frames to 10 and click on the Play button to see the animation of the deformation.

You can also find the play button on the Post Control Toolbar itself.

![Animation Setup Window]

You can now see an animation of how the impeller is deformed as the loads are applied to the blades.

- To make any setting changes in the results display click on the Postview icon as shown in figure below.

![Post View Window]

- In the popped up ‘Post View’ Dialog box click on DEFORMED RESULTS under DISPLAY tab button.

- In the ‘Deformed results’ dialog box check the Undeformed as shown in the second figure below and Choose OK twice.
Now press on the Play button to see the animation. This will show the animation of deformation with the original shape in Grey color, as shown in the figure below.

- Click on the Stop button.
- Click on the Finish icon on the toolbar to finish the Postprocessing.

There are two ways to improve the accuracy of FEA results.
- Reduce the size of element
- Increase the order of interpolation polynomial (i.e. use quadratic or even cubic instead of linear polynomials)

The second approach is preferred because it is more efficient in terms of computation time and takes less memory space. However, let's try to create a scenario using the first option.

- Right-click on scenario_1 in the Scenario Navigator
- Choose CLONE to copy the first scenario.
Choose OK on the Message box.

Once Scenario_2 is created, click on the plus sign next to 3D Meshes

Then double-click on the subheading 3d_mesh to edit the parameters

In the dialog box shown, change the Type to TETRA4.

Choose OK

Click on the Solve icon to solve the scenario.

Click OK

The Analysis Job Monitor should show Scenario 2 to be complete.

Click CANCEL

In the Scenario Navigator, double-click on Results for scenario 2.
The figure below shows the analysis. You can observe the change in the maximum deviation. Save all the scenarios and Close the files.

10.4 EXERCISE-ARBORPRESS L-BAR

Open the file ‘Arborpress_L-bar.prt’ and do a similar structure analysis, considering the material to be steel. For the mesh, the element size should be 10.00 and the type Tetra10.
For the loads, apply a normal pressure with a magnitude of 500 on the top surface as shown in the figure below.

For the boundary conditions, fix the three flat faces (the front highlighted face, the face parallel to it at the backside and the bottom face) as marked in the following figure.